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Introduction 

SpinWorks has two functions: The first is to provide easy basic off-line processing of 1D, 2D 

and 3D NMR data on personal computers. SpinWorks other function is the simulation and 

iterative analysis of complex second order spectra including dynamic NMR problems and certain 

solid-state NMR problems, in a manner similar to our old UNIX Xsim program.  

SpinWorks 3.0 was the first release of SpinWorks intended to run under the Microsoft .NET 

environment.  Full support is included for Bruker (XwinNMR/UXNMR), Varian (Unix 

VNMR/VNMRJ) and Anasazi (CDFF type 2) data formats.  JCAMP-DX format is supported for 

1D only.  JEOL 2D is now supported but still needs testing.  Included indirect detection modes 

include States, TPPI, States-TPPI, Single Detection (QF), and echo-antiecho.     

Bruker DISNMR and DISMSL format data are no longer supported. 

While the program is to the point where it should (I hope) be useful, there will, no doubt, be bugs 

and there are things that don't yet work. The aim of the program is to make a program easy 

enough for undergrads to process magnitude COSY spectra (for example) with a single mouse 

click, and yet still be flexible enough for research use. 

SpinWorks currently handles up to 7 data sets at a time.   

Things that don't yet work, or need improvement in SpinWorks 4: 

1. The .NET version is a bit of a memory hog.  This is because all of the data remains memory 

resident.  This does, however, greatly speed up the processing.  2D Imaginary quadrants can 

be cleared from memory after transform and phasing.  2D matrices up to 2k by 1k shouldn't 

create problems on a machine with 256 MB of ram.  You may want to watch how many other 

programs you have running, however. A 4k by 1k TPPI HSQC uses up about 32 MB of 

memory.  Considerable additional memory is used transiently during transform and display 

contouring.  

2. Not enough OS/printer/printer-driver combinations have been tested.  In particular, I would 

like to hear from anyone having printing problems with Linux. 

3. 2D MQMAS shearing transforms still need more testing with Bruker data. 

4. Linear prediction is a bit slow compared to earlier versions.  However, the LP routines are 

now .NET clean and should run under other .NET environments (e.g. Mono). 

5. For Varian data, the referencing values imported with the dataset may be off by one data 

point.  This is not normally noticeable for data with a large number of points (usually 1D), 

but may be annoying on smaller (usually 2D) datasets.  Using the SpinWorks Calibrate 

function will correct this problem. 

6. For normal processing, SpinWorks doesn’t care if there are blanks embedded in the path to 

the data.  For example, if you put your NMR data in the “My Documents” folder (with the 

blank between “My” and “Documents”) SpinWorks won’t care.  However, the UNIX-

derived dynamic NMR simulation routines (DNMR3 and MEXICO) won’t tolerate blanks in 
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a file path (because UNIX doesn’t like blanks in a file path).  So, if you are running DNMR 

or MEXICO simulations with experimental data present, the data must be in a folder with no 

blanks in the entire path.  For example, create a folder like C:\nmrdata (or whatever), put 

your data there, and everything will be fine.  Note that some vendors’ software now allows 

blanks in file names, but I think practice should be discouraged. 

7. The autophase routine really sucks!  Does anyone have a good algorithm that they want to 

share? 

8. The Linux version still needs a lot of work.  Or, I might say, the mono run-time needs a lot of 

work.  On many printers, the Linux version can’t seem to print in landscape mode.  There has 

been a report that the “Copy to Inset Box” feature doesn’t work under mono, but I have not 

been able to reproduce this problem. 

9. The simulation modules still need to be compiled for Linux. 

Fonts 

In this manual, Arial is used for menu items and other text that you see on the screen.  Bold 

italics means: listen up, this is important! 

Timings 

Sample 2D transform timings (with image mode display) on a 1.86 GHz CoreDuo 2 GB (Dell 

Precision 390) under WinXP:  

 4k by 512 States HSQC with phasing applied in F1:      6 sec. 

 1k by 1k States TOCSY with phasing applied in F1:  ca 2 sec. 

 Contour display of 1k by 1k TOCSY (Strychnine):    ca 2 to 3 sec. 

What does the message “Display buffer exceeded, raise the floor!” message mean? 

It means that the lowest display level (contour or image) is too low.  Simply click the Floor + 

button (button panel).  You may have to click several times is the level was much too low. 

Computer Requirements 

SpinWorks requires a Pentium class processor running Windows XP, Windows Vista, Windows 

7 or Windows 8. Installation currently requires about 12 Mbytes of disk space exclusive of NMR 

data.  512 Mbytes or more of RAM are recommended, depending on NMR data set and 

simulation sizes.  Of course, more memory is required for 2D and 3D!   

SVGA 1024 x 768 or better display required (1280 x 1024 or better recommended).    

Release 2.0 (or higher) of the .NET runtime environment is required.  This can be downloaded 

from Microsoft and is also included on the SpinWorks ftp site.  Release 4 or higher is 

recommended. 

For 2D you should also have your display set to at least 16 bit colour, otherwise the image and 
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contour level colours will be strange.  

A three-button mouse is ideal, but SpinWorks will work just fine with a two-button mouse.  Note 

that on "Wheel Mice" the mouse wheel can serve as the middle mouse button.  The mouse wheel 

can also be used for vertical scaling of 1D spectra or the “projection” traces of 2D spectra. 

64 vs 32 Bit Operating Systems 

SpinWorks seems to work just fine under 32 bit versions of Windows, as well as 64 bit versions 

of Windows 7 Windows 8 and 64 bit Vista. The default folder for 64 bit systems is C:\Program 

Files (X86)\SpinWorks_4.  In order to use the simulation modules on 32 bit versions of 

Windows you must update the External Module Path entry (Options menu, Set Start-Up 
Options… selection) to C:\Program Files\SpinWorks_4 to reflect this difference.  If you have 

installed SpinWorks in a non-default location them you must also edit the External Module 
Path to reflect the actual install location. 

It turns out that there is a bug in .NET for Windows 7 64 bit (maybe Vista 64 bit? maybe 

Windows 8?) in that the Print Dialog box doesn’t work.  A workaround has been to use the print 

button in the Print Preview dialog.  Starting in 3.1.8 beta 4, an option has been added to use an 

alternate Print Dialog.  This can be selected with the Set Start-up Options… dialog in the 

Options menu. 

Mono 

I am hoping that the program will run under other releases of .NET, such as the open source 

mono project under LINUX or MacOS X.  I am currently testing SpinWorks running under 

MONO 3.0.6 on OpenSUSE 13.1.  A slightly modified version of SpinWorks also seems to 

compile just fine with MonoDevelop 3.0.6 under OpenSUSE13.1.  Testing so-far has been 

encouraging, but there are still a few minor snags to be straightened out.  The external simulation 

modules have not yet been compiled for Linux. 

SpinWorks seems to run just fine under “Parallels” or “Boot Camp” on Macs and “Wine” on 

Linux. 

Download 

The program is currently available by anonymous ftp from ftp://davinci.chem.umanitoba.ca in 

the pub/marat/SpinWorks/ directory.  The current release is SpinWorks_405.zip.  The 

documentation, available as a pdf file, is available for separate download, but is also included in 

the zip distribution. 

Installation 

Run the setup.exe program in the unzipped folder and follow the instructions.  In most cases, it is 

safe to use the default settings.  Please read the license agreement and agree with the conditions 

before proceeding.  The installation procedure will add the program to the Start menu and make 

a shortcut on the desktop.   
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Windows Command Line Start-Up 

SpinWorks can be started from the Windows command line and given the full path to start-up 

data set as a command line argument.  For example, a command line entry like: 

 SpinWorks.exe C:\nmrdata\cyclosporin\1\fid  

will start SpinWorks on and load the fid for experiment 1 on the cyclosporine data set.  If the 

path to the data contains any blanks, it will be necessary to enclose the path in quotation marks.   

E.g. SpinWorks.exe “C:\my nmrdata\cyclosporin\1\fid”. 

If the “autoload” feature is turned on and data set contains processed data, this will be displayed. 

This feature can be very useful if one wants another program or web browser to display an NMR 

data set by launching SpinWorks. 

Registry Entries 

SpinWorks 4 uses a different set of registry entries than earlier (release 2 and 3) SpinWorks 

versions.  This means that you will probably want to go to the Options menu and use the Set 
Preferences… dialog to configure you start-up preferences.  Usually, this will mean just setting 

your start-up data path and a few desired defaults… a few seconds at most.  Display colours and 

the recent files list are also stored in the registry. 

Redistribution 

You are free to redistribute this software to others, provided that: 

 You don’t charge anything for it. 

 You don’t modify it. 

 You distribute it in its entirety. 

 If you download the source code and make your own modifications, you are free to 

distribute the modified version provide that you clearly indicate that this is a modified 

version. If you make modifications that you think might be useful to others, please 

forward them to me and I will try to include them in the trunk version. 

Registration 

Although SpinWorks is currently being distributed as freeware, and there are no license keys 

required. I do, however, request that a SpinWorks user register their use by email to: 

kirk.marat@.umanitoba.ca 

Please include: an email contact, the machines and OSs that you are running it on (e.g. i7 3.4 

GHz, Win 7 Pro), and a note of any problems etc. that you had with the download and 

installation.  I intend (someday) to maintain an email list so that I can inform users of bugs, 

updates, patches, etc.  If you don’t want to be on this list, please let me know. 

mailto:kirk.marat@.umanitoba.ca
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More detailed comments, questions, bug reports, etc. can be also directed to the above address, 

and are always (!)  appreciated. 
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Obligatory Disclaimer (Lawyer Talk)  

SpinWorks is being distributed as “freeware” in the hope that it will be useful.  However: 

The author disclaims all warranties with regard to this software, including all implied 

warranties of merchantability and fitness. In no event, shall the author or the University of 

Manitoba be liable for any special, indirect or consequential damages, or any damages 

whatsoever resulting from loss of use, data or profits, whether in an action of contract, 

negligence or other tortuous action, arising out of or in connection with the use or 

performance of this software.   

All trademarks mentioned (e.g. XwinNMR, TopSpin, VNMR(J), Windows, etc.) are property of 

their respective owners. 

Referencing SpinWorks 

Please check the “Instructions to Authors” for whatever journal you are writing for, but it should 

be something like:  

SpinWorks 4.1.0, Copyright © 2014  

Kirk Marat 

University of Manitoba 

If you make use of the simulation modules (DNMR3, MEXICO, NUMMRIT or SIMPSON) you 

must, of course, reference the original authors work as well.  These references are given in the 

corresponding section of this manual 

Online Help 

PDF and Word format manuals are available.   The standard windows help has been phased-out, 

and may be replaced with and XML or HTML based help system.  The manual can also be viewed 

directly from SpinWorks in PDF format (requires Adobe Acrobat reader) or in Word format 
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(requires a word processor). 

Error Logging 

SpinWorks logs exceptions and other error conditions into a log file (SW_error.log) in the folder 

defined as the scratch folder (usually C:\Temp).  This is the first place to look if there is a 

problem with the program.  Additional more detailed program tracing information can be 

generated by selecting Extended Debug Logging in the Options menu. 

FTP Clients 

Bruker and Varian data seta are directory (folder) structures containing a mixture of binary data 

and ASCII parameters and text.  FTP transfer of binary data with the ftp client set to ASCII will 

result in a corrupt data set.  Some FTP clients (notably FileZilla) have an “auto” setting which 

unfortunately doesn’t detect the binary data properly.  For these clients set the transfer type to 

binary (or bin) and everything should be fine. In FileZilla this is the transfer type setting in the 

Transfer menu.  Transferring the ASCII parameters in binary mode creates no problems. 

New (or different) in version 3 relative to version 2.5.5 

1. New, streamlined, more colourful user interface.  (I got tired of the Microsoft battleship 

gray.) 

2. Requires .NET 2.0 or higher. 

3. More options and flexibility for stacked and inset plots. 

4. More options for colours, font sizes, etc. 

5. Provisions for automatic processing and peak picking of Varian “Arrayed” experiments. 

6. Several selections have been moved from one menu to another.  For example, “Peaks and 
Match” has been moved from Options to View. 

7. The keyboard shortcuts for recalling regions of interest have been changed to: <Alt>1, 

<Alt>2 and <Alt>3. 

8. Added FID math toolbox. 

9. Added support for JCAMP-DX FIDs produced by XwinNMR/TopSpin. 

10. Added support for JCAMP-DX Spectra produced by Tecmag NTNMR. 

11. Added support for solid state simulations (spectra and FIDs) produced by the SIMPSON 

program. 

12. Uses Bruker “FnMODE” parameter (if defined) for F1 quad detection setting.  This 

parameter was added with TopSpin (possibly XwinNMR3.5 as well).  If FnMODE is not 

defined then the MC2 parameter is used.  This is consistent with the way TopSpin handles 

the data. 

13. Added manual 1D and 2D peak picking using right mouse button. 



  

SPINWORKS 4.1 MANUAL 11 

 

14. Removed “double-click” toggle of the data area cursor.  The View menu or the keyboard “t” 

shortcut can be used instead. 

15. Added support for 2D and 3D processed data produced by NMRPIPE. 

16. Added peak deconvolution (band fitting). 

17. Added 1D and 2D Hilbert transforms. 

18. Added manual picking of individual peaks. 

19. Fixed “blank-free” file path restriction for NUMMRIT simulations. 

20. Versions 3.1.1 to 3.1.5 add numerous small enhancements and bug corrections.   Many of the 

bug corrections correct problems resulting from many parts of the world using a “,” as the 

decimal separator rather than “.”  As used in North America.  Note, however, that all values 

entered into dialog boxes in SpinWorks must use the North American “.” Decimal 

separator. 

21. Plot sized and options (sizes and objects) are saved with the processed data (3.1.3).  A default 

option for A4 paper size has also been added (3.1.3). 

22. Added command line start-up with a specific data set (3.1.4). 

23. Added error logging and tracing (3.1.5). 

24. Increased number of workspaces to 7 (3.1.5). 

25. Added keyboard shortcuts “z” for zoom, “f” for full spectrum, and “l” for last expansion 

(3.1.5). 

26. Added Return (Enter) key as a shortcut to exit baseline peak pick minimum routines (3.1.5).  

27. Added log spacing for 2D contours, and made this the default.  Linear spacing can be 

selected in the View menu (3.1.5). 

Added in 3.1.6 

28. Added support for JEOL 1D data (JEOL 2D is still under development). 

29. Added cubic spline baseline correction. 

30. Added “sum” mode to the projection display and calculation.  Previous projection calculation 

was “skyline” only. 

31. For band fitting x,y points files of the individual peaks as well as the synthetic spectrum can 

produced. 

32. Added summing a stacked trace to the experimental. 

Added in 3.1.7 

33. Added support for Anasazi format data (1D and 2D, FIDs and spectra). 
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34. Many small (and not so small) bug fixes. 

35. The code is hopefully more “Linux friendly.” 

36. Improved JCAMP-DX format handling.  Packed, Squeeze and Diff/Dup compression modes 

are supported. 

37. A Dual 2D display mode has been added. 

38. Improved processing for Bruker “arrayed” (T1, diffusion, etc.) type experiments that are 

recorded as a pseudo-2D experiment in a ser file. 

Added in 3.1.8 

39. The fully automatic baseline correction routine has been greatly improved.  The “Whittaker 

smoother” routine is used. 

40. The FID display has been improved, and the current window function is displayed with the 

FID. 

41. Font Size Options added.  Standard menu and button panel fonts slightly bolder and 

(hopefully) more readable. 

42. Alternate print dialog box (Set Start-up Options…) for Windows 7 64 bit. 

43. Added data “binning”. 

New (or different) in version 4.0.5 relative to version 3.1.8 

1. 3D Processing (Bruker and Varian/Agilent data only). 

2. Workspace buttons as an alternative to the Workspace drop-down (drop-down may be 

deleted in future versions). 

3. An option for coarse vs. fine contour level spacing (View menu).  The coarse setting is the 

default, and speeds up the 2D display. 

4. Integration slope and bias added.  Slight change in the way a current integral is defined. 

5. Increased default Whittaker Lambda value for fully automatic baseline correction. 

6. Peak Pick menu now includes an option for setting the number of digits to the right of the 

decimal. 

7. Referencing dialog includes buttons for setting the reference to common solvent values (1H 

and 13C). 

8. Fixed several bugs in the JCAMP-DX file reading routines. 

9. Option for setting number of digits for integral and peak display. 

10. Integrals and peaks are automatically read in when loading processed data. 

11. The increase and decrease Bruker experiment number buttons will now skip gaps in the 
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experiment number list. 

12. You can automatically process and stack display a series of Bruker experiment numbers (e.g. 

for a 1D NOE or ROE series or time study. 

13. Scaling of metafiles has been changed internally as a work-around to a bug in MS Word’s 

pdf creation procedure.  These changes should be transparent to the user. 

14. Start-up defaults are suitable for 64 bit operating systems (32 bit still fully supported). 

Added in 4.1 

1. You can drag the mouse to zoom a region of the spectrum in both 1D and 2D. 

2. Vertical reset button added. 

3. JEOL 2D is now supported (but still in testing phase). 

4. Added support for Magritek data. 

Use of the Mouse, and General Display Manipulation 

While the cursor is in the data window, a left mouse click can be used to mark one or two red 

reference lines on the spectrum.  A third click will remove the lines. The frequency and frequency 

difference of these lines is displayed on the screen and can be used to estimate shifts and couplings, 

etc.  These lines are also used by several routines that require defined reference points.   

Spectra can be zoomed by dragging the mouse cursor over the desired with the left mouse button 

down.  Simply place the cursor at one end of the region of interest, press the left mouse button and 

drag the cursor to the other end of the region of interest.  An alternative (the old method) is to define 

the region with two left clicks and then zooming with the zoom button, the z key or a middle mouse 

click. 

The function of the right mouse button (on both two- and three-button mice) in 1D depends on the 

presence of simulated data. If there is an experimental spectrum present but no simulated spectrum, 

the right mouse button can be used for manual peak picking.  The program will use the current peak 

picking parameters (minimum intensity and noise threshold) to try to find a peak within a 

reasonable distance from the current cursor location.  If no peak is found (or interpolation is turned 

off), the raw cursor location is used as the peak location.  These manually picked peaks are 

appended to the current peak list, so that a mixture of normally picked peaks and manually picked 

peaks can be created.  This can be very useful if you want a peak list to include peaks that are 

difficult (broad and/or noisy) for the automatic peak picking algorithm to detect. 

If there is a simulated spectrum as well as an experimental spectrum, the right mouse button is used 

to assign calculated transitions to observed lines, but only when the pointer is actually within the 

data window (the part of the screen displaying the spectra).   

In 2D mode the right mouse button selects rows or columns of the 2D matrix (e.g. for phasing), or 

can be used for interactive 2D peak labeling/picking. 

Display colours can be set with the Display Colours… dialog in the Edit menu. 
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Figure 1. Typical 1D display 

Spectral regions can be zoomed by defining two reference points and clicking the  
button on the right hand button panel, or the middle button of a three-button mouse. Spectra can also 

be zoomed with the z keyboard shortcut.  

Spectra can also be expanded and contracted with the buttons labeled   . 

A tracking vertical cursor line can be turned on/off with the appropriate selection in the View menu 

of with the “t” keyboard shortcut.  

The scrollbar at the bottom of the data window can be used to pan through an expanded spectrum.  

The spectrum baseline or zero can be moved by “dragging” it with the cursor.  This works for both 

experimental and simulated data. 

A number of specific display limits or plot scales (e.g. 9 to -0.5 ppm or 10 Hz/cm) are available 

through the View menu.  The button panel Full button will always show the full recorded spectral 

width. 

1D Spectra are scaled vertically with the button panel + and – buttons. The yellow buttons are for 

the experimental spectrum and the bluish buttons are for the simulated spectrum.  Spectra may also 

be scaled in smaller steps with the keyboard up and down arrow keys. You can also (and most 

conveniently) adjust the vertical scaling with the mouse wheel (if you have one).  You can adjust 

the experimental spectrum with the cursor is in the bottom half of the screen, and you can adjust the 
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simulated spectrum with the cursor in the top half of the screen.  

It is possible to expand regions of a 1D spectrum and display it in inset boxes.  Simply define the 

region with the cursors and select Copy to Inset Box on the View menu.  The cursor-defined 

region will be displayed in a re-sizable box.  Likewise, the button panel controlling the scaling of 

the inset trace can be closed and then re-opened at any time with the Scale/Shift Stacked or Inset 
Traces… selection in the View menu.  Note that the vertical scaling of the inset is completely 

independent of the regular spectrum scaling, but the relative scaling of the two is always shown in 

the upper left corner of the inset.  The relative scaling of the inset can be set to be the same as the 

regular spectrum by using the reset button on the Scale and Shift Stacked or Inset Traces dialog 

box. 

Up to three regions of interest (regions that you might want to look at again) may be defined for 

each spectrum.  You can define these regions with the Define User Specified Limits… dialog 

from the View menu, and the saved region can be displayed with the ROI menu.  You can also use 

<ctrl>1, <ctrl>2 or ctrl<3> to define the current screen view as a region of interest.  The regions 

can then be recalled with the ROI menu or the <Alt>1, <Alt>2, or <Alt>3 keys.  These regions of 

interest are saved with processed data saved by SpinWorks (when the auto save feature is on) and 

recalled when the data is retrieved.  These regions are not saved with data in JCAMP-DX format. 

In 1D mode, SpinWorks can display the experimental spectrum, a simulated spectrum, and a 

series of stacked traces.  It is important to note that there are slight difference between the 

experimental trace, the simulated trace, and the stacked traces. 

1. The size, spectral width and offset of the simulated trace are equivalent to the experimental 

spectrum.  In essence, the spectral characteristics of the simulated trace are tied to the 

experimental spectrum. 

2. The size, spectral width and offset of the stacked traces are independent of the experimental 

data.  Each stacked trace is an independent object, and its spectral parameters are copied from 

the source spectrum when the stacked trace is created.  This allows one to compare spectra 

that may have been recorded under different conditions. 

Keyboard Arrow Keys 

The keyboard left and right arrow keys move the simulated spectrum transition cursor from peak 

to peak.  Holding the <ctrl> key down while pressing the arrow keys moves the cursor in steps of 

5.  This is very useful for moving the cursor rapidly on a spectrum with many degenerate or near 

degenerate transitions.   

The keyboard up and down arrow keys adjust the vertical scale of the experimental spectrum.  

The scaling steps are smaller than those of the toolbar + and – buttons.  Holding the <ctrl> key 

down while pressing the arrow keys scales both the experimental and calculated spectra. 
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Keyboard Function Summary 

Left and Right arrows Move the simulated spectrum transition cursor.  Holding the <ctrl> 

key down at the same time moves the cursor in steps of 5 

transitions 

Up and Down arrows        Adjust the vertical scaling of the experimental spectrum.  Holding 

the <ctrl> key down at the same time adjusts the scaling of both the 

experimental and simulated spectra. If you have a "Wheel Mouse", 

you can use the mouse wheel to adjust the vertical scaling of 1D 

spectra.  If the pointer is in the bottom half of the data window the 

scale of the experimental spectrum will be adjusted.  If the pointer 

is in the upper half of the screen the scaling of the simulated 

spectrum will be adjusted. 

“t”  key  Toggles the tracking cursor (2D cross-hair pointer) on or off.  This 

is an alternative to using the Options menu.  Double clicking in the 

data area will also do this. 

“a” key                      Assigns the transition pointed to by the transition cursor to the 

nearest observed line.  This function uses the peak picking 

algorithm, so is influenced by the peak picking threshold and noise 

discrimination factor. 

 “d” key                        Deletes any assignment for the currently pointed to transition. 

 “z” key  Zooms the region between the cursors. 

 “f” key  Displays the full spectrum. 

 “l” key  Displays the last expansion. 

 

<Ctrl>1, <Ctrl>2, <Ctrl>3 Defines the currently display as a region of interest that can be

 recalled later.  You can also define these regions from the View 

 menu. 

<Alt>1, <Alt>2, <Alt>3  Recall a previously defined region of interest.  The ROI menu 

 from the menu bar can also be used. 

Toolbar 

The toolbar is displayed across the top of the application window, below the menu bar.   The 

toolbar provides quick mouse access to several SpinWorks functions: 

   Open an existing NMR data set.  SpinWorks displays a dialog for 

selecting data sets.  
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Selects the current workspace.  There are 7 available workspaces.  Starting 

in SpinWorks 4 there are a series of workspace selection buttons to the 

right of the Workspace pull-down. 

   Decreases or increases the experiment number for Bruker data. 

  

Decreases or increments the current 3D plane number. 

   Print the current NMR spectrum.  Various plot options can be set with the  

  Plot Options and Parameters… dialog available in the Edit menu. 

   Save the processed spectrum in JCAMP-DX format in the current data 

folder.  The file will be named: “spectrum.dx”.  In order to save the file 

with a particular name, use the Save As… selection in the File menu.  

This button is most useful for saving 1D reference spectra to plot along the 

axes of 2D spectra.  A copy of the processed data is also saved in 

SpinWorks own format as well. 

   Saves a copy of the current output as a Windows enhanced metafile (emf) 

in the Windows clipboard.  These files can be used to include the spectrum 

in documents, etc.  

   

Define the pre-transform window (weighting) and post-transform phasing 

to be applied with a 1D Fourier transform. 

Button Panel 

The button Panel at the right of the data window can be used for display manipulation and 

processing.  The number and identity of these buttons will change with the current state of the 

program.  The buttons are grouped and colour coded according to function.  Cyan (blue-green) is 

for display functions, green in for processing and yellow starts post-processing dialogs and 

routines such as interactive phasing. 
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 The  buttons scale the spectra vertically.  The colour of the symbol on the 

button matches the colour of the spectrum. In 2D mode, these buttons control the 

scaling of any displayed rows or columns.  If you have a "Wheel Mouse" you can use 

the mouse wheel to adjust the vertical scaling of 1D spectra.  If the pointer is in the 

bottom half of the data window, the scale of the experimental spectrum will be 

adjusted.  If the pointer is in the upper half of the screen the scaling of the simulated 

spectrum will be adjusted.  In 2D mode, the buttons with the Scale: label to the left 

adjust the scaling of any displayed rows or columns. 

 The  buttons are used in 2D mode to highlight a particular overlaid row or 

column.  In an arrayed experiment (Varian) selects the index of the array. 

 The  buttons contract and expand the spectra horizontally.  Usually, it is 

easier to use the cursors and the  button, but some routines (e.g. 

integration) pre-empt the cursor for their own purposes.  Not available in 2D mode.   

 The ,  and  buttons Zoom the spectrum between red 

two cursor lines, return to the full spectral width, or return to the previous expansion, 

respectively.  Note that if you have defined a region with two cursors lines, you can 

use the middle mouse button (if you have one) or the Z keyboard shortcut to zoom in 

place of the blue Zoom button.  The F keyboard shortcut will display the full 

spectrum while the L keyboard shortcut will display the last expanded region. 

 The  /  button switches between 1D and 2D display mode for 

2D data.  The label on the button described the action of the button, and not the 

current display state of the program.  i.e.  If you are displaying 2D data in contour or 

image mode, the button will be labeled 1D Display in order to switch to 1D mode for 

displaying individual rows. 

 The  /  button switches the 2D contour and image displays 

between displaying only positive intensities (e.g. for magnitude mode spectra) and 

displaying both positive and negative intensities (e.g. for phase sensitive data). 

 The   button starts the processing parameter dialog (1D and 2D). 

 The   (1D) button is used to process the data with the current processing 

parameters.  The pre-transform window (weighting) function and the post-transform 

phasing can be set with the tool-bar drop-down menus.  In 2D mode, the  

button will process both dimensions according to the current processing parameters. 
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 The   button starts the interactive phasing routine. (1D and 2D) 

 The   button starts the integration routine. (1D and 2D). 

 The  button calibrates the spectrum.  To calibrate a spectrum: define a 

point with a cursor line, click the Cal button, and then enter the correct value in Hz. or 

PPM (depending on the current axis units).  In 2D mode, you will be asked for the 

calibration in both dimensions. 

 The   button starts the baseline point routine. Not available in 2D mode.  

After all baseline points have been defined click the button (now labeled return) again 

or hit the Enter key to exit the baseline routine. 

 The    button starts the pop-up simulation panel. 
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Getting Started: Basic 1D NMR Processing 

1.  Setting the Data Format (not normally necessary) 

SpinWorks 4 can identify the most common formats (VNMR, XwinNMR/UXNMR/TopSpin, 

JCAMP-DX, JEOL and Anasazi) automatically. In order to process data in other supported formats 

or processed data from NMRPIPE, use the Data Format... selection in the Options menu.    The 

Varian/Agilent setting is for Varian Unity, Unity+, Mercury, Inova, VNMRS, DDR, DDR2 and 

MR400 spectrometers.  VXR/S data will probably also work with this setting, but this hasn’t been 

tested.  VXR, Gemini and XL data formats are not supported.   The Bruker setting is appropriate for 

data from a Bruker AMX, ARX, ASX or Avance series spectrometer.   DISNMR / DISMSL data 

are no longer supported.  JEOL data support is currently limited to the “jdf” format, 

1D FIDs in JCAMP-DX format written by XwinNMR or TopSpin can be read and should be 

automatically recognized by the program.  1D Processed data can also be read and saved in JCAMP 

DX format. 

Part of the design philosophy of SpinWorks is that it uses the data in the format provided by the 

spectrometer.  Any and all format conversions are internal to the program and are essentially 

transparent to the user.  This also means that the complete data set must be transferred to your PC!  

For UXNMR/XwinNMR data, the entire data tree from the experiment name down should be 

transferred.  This is important, since SpinWorks gets referencing and processing information from 

the proc and procs files, and expects to find them in the same relative place that they were on the 

spectrometer.  For Varian data, SpinWorks expects to find the fid, procpar and text files under the 

experiment_name.fid directory.  The easiest way to transfer entire directories with contents to your 

PC is with one of the smart ftp programs such as WS_FTP95, “FileZilla” or similar.  Note that the 

file transfer mode must be set to binary.  This seems to be a particular issue with FileZilla. 

Tip for JEOL and Anasazi data:  Bruker, Varian and NMRPipe data sets are actually folders 

contain a number of data and parameter files.   SpinWorks writes processed data, simulation files 

etc. into this folder.  JEOL and Anasazi data can be problem in that the data sets are single files, 

whereas many features of SpinWorks assume that a data set is a folder.  An easy work around it to 

create a folder for each JEOL data set.  For example, if you have a data set called brucine_1D1H.jdf 

just place the file into a folder called brucine_1D1H.  All SpinWorks created files will then be 

placed into the folder with the raw data set. 

2.  Selecting the Data 

Data selection is done with Open... selection in the File menu. You will then be presented with a 

standard Windows file selection menu.  Navigate through directory system and select your data. For 

Bruker AMX and Avance data, navigate from the experiment name directory to the experiment 

number directory and select the file named "fid".  A “recent files” selection is available at the 

bottom of the File menu and can be used as a shortcut for data selection.  If you have selected a 

valid data set then it will be displayed on the screen after closing the File menu.  JEOL files will 

have a “.jdf” extension while Anasazi files will have a variable (or no) extension.  Anasazi data can 

be either time domain (fids) or processed spectra.  For Anasazi 2D, it may be necessary to specify 
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that the data are 2D after selecting the data set (Data Format selection in Options menu). 

Tip:  The Default Data Path setting in the Set Start-Up Options… dialog in the Options menu 

is a convenient way to short cut selection of your data. 

Data on CD:  SpinWorks occasionally writes scratch files, processed data or other information, 

usually in the same folder as the experimental data.  This creates a problem for data on CDs (or any 

other write-protected file system) where you cannot usually (except for CD-RW) write data.  

Therefore, data on CD must be transferred to the hard disk before processing with SpinWorks.  This 

also means that you must have write permission in the folder where the data are located. 

3.  Processing Data 

1D data processing involves application of a window function (Exponential Multiplication) 

followed by Fourier transformation.  These two processes are combined in the window+ft selection 

in the Processing menu.  The other selections are for more advanced processing.  The line 

broadening parameter for the exponential multiplication can be set in the Processing 

Parameters... selection of the Edit menu or the  button on the button panel, but a 

reasonable parameter is set by default.  After processing, a spectrum will be displayed on the screen. 

The  button on the right hand button panel will process the spectrum with the window 

function and phasing options selected by the drop-downs on the menu bar. Note that it is not 

necessary to re-read a data set to reprocess it.  Once a data set has been selected once, (e.g. via the 

File menu) then one can just issue processing commands - the program will automatically re-read 

the raw data from disk each time.   

Sometimes, there is a DC bias in the FID, which can cause a zero frequency spike in the spectrum.  

This can be removed by checking the FID bias correction in the 1D Processing Parameters… 
dialog.  FID bias correction is not the default setting for two reasons:  Low frequency signals near 

the centre of the spectrum (usually water) can cause problems with the algorithm; Modern 

spectrometers have very little DC bias in their receivers.   Systems with digital receivers (Bruker 

Avance, Varian VNMRS) should have no DC bias in the signal. 

However, for spectra with a low number of scans, especially if the number of scans is not a multiple 

of the phase cycle, bias correction might be required on older systems. 

A pronounced baseline offset in the spectrum can usually be corrected by adjustment of the First 
Point Correction parameter (1D or 2D processing parameter dialogs.).  Typical values will be in 

the 0.4 to 0.6 range (the theoretical value is 0.5).  Note that any baseline offset in the spectrum as 

well as reasonable amounts of baseline curvature can also be removed after processing with the 

baseline correction features in the Processing menu. 

Resolution enhancement may be applied by setting the window type to Lorentz to Gauss.  The LB 

parameter should be set to a negative value, with the negative of the natural line width being a good 

starting point.  The GF parameter should be set to the relative fraction of the FID where the signal 

decays into the noise.  For example, it the spectrum has peaks with a natural linewidth of 1 Hz, and 

the FID is gone 1/3 of the way into the acquisition time, then set LB to –1.0 and GF to 0.33.  Set the 
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Window function to Lorentz to Gauss and Process the data. Some experimentation may be 

required. Note that resolution enhancement may alter the relative integrals of the signals.   

The TRAF function provides resolution enhancement as described by Traficante and Ziessow in J. 

Magn. Reson. 66, 182 (1986).  This function uses the LB parameter to calculate T2.  Optimum 

performance is usually achieved when LB is set to the linewidth of the peaks in the absence of any 

apodization, but some experimentation may be required.  Usually, a smaller value of LB will be 

needed for an acceptable signal to noise ratio.  For routine organic samples in CDCl3, a value of 0.5 

to 1.0 Hz seems to work well.  A larger value will provide more enhancement, but a poorer signal to 

noise ratio. 

The TRAFS function is a modification of the function which optimizes both the resolution and 

signal to noise ratio, as described by Traficante and Nemeth in J. Magn. Reson. 71, 237 (1987). 

The Gaussian selection in the processing panel applies a pure Gaussian window function to the 

time domain data. This function uses the LB parameter (not GF).  In this case, the LB parameter 

specifies the width of 1  in the normal distribution, and is slightly closer to the baseline than half-

height. 

HOGWASH resolution enhancement is left for a later section. 

4.  Linear Prediction 

There are two situations where backward linear prediction may be useful for 1D spectra. 

The first is where the first few points are corrupted by probe ringdown, wideline background, 

acoustic ringing, etc.  In this procedure, the first few points of the FID are discarded and replaced 

with a backward extrapolation of the remaining data. After selecting a data set, the parameters 

for backward LP may be set in the Edit Processing Parameters… dialog of the Edit menu.  

The number of points to predict will typically be 2 to 16, and should be an even number.  The 

number of coefficients will typically be 16 to 32, while the number of input points used for 

prediction must be greater than or equal to twice the number of coefficients.  Generally, the more 

input points the better. However, specifying too many will result in noisy regions of the FID 

being used in the calculation of the coefficients.  64 Input points are suitable for many cases. The 

linear prediction itself is applied as part of the next transform.  The cutoff parameter specifies a 

significance level for the coefficients.  The default value is usually good, but may be raised to 

speed calculation.  The FID can then be processed normally with any of the usual 1D processing 

functions in the Processing menu or the Process button.  If the selection of LP parameters was 

inappropriate, make the necessary changes and re-process.  Note that backward LP in SpinWorks 

always uses the SVD algorithm. 

The second situation occurs with spectra recorded with very wide spectral widths, typically in 

solid state NMR.  Here, the first data point is sampled after many dwell times, although the 

Fourier transform assumes that the first point is at zero time.  For example, with a spectral width 

of 2.5 MHz, the dwell time (time per data point) is 200 ns, while the “DE” value on our Avance 

III 500 is about 8 µs.  This means that the first data point (which should be at time zero) is 

sampled about 40 dwell periods too late.  This creates a huge (~ 6000°) first order phase 
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correction which then results in baseline “issues”.  The trick here is to right shift (that’s correct, 

right shift) the data so that the first sampled data point occurs at the proper time in the fid.  In a 

normal right shift, the points at beginning of the fid are filled in with zeros while the points at the 

end of the FID are lost.  However, the zero points at the beginning of the fid can also be replaced 

by back-predicted points based on the remainder of the fid.  In SpinWorks, this is accomplished 

as follows: 

1. For Bruker dsp filtered data  (essentially all recent Bruker instruments), you must first 

convert the data from “digital” to “analogue” by using the “convdta” command in 

TopSpin or XwinNMR.  This must be done with the Bruker software, as there is currently 

no equivalent function in SpinWorks. 

2. For Bruker data, divide the DE value by the dwell time (DW = 1 / (2*SW)).  In the 

example above, 8 µs / 200 ns = 40 points.  If the number is not even, round down to the 

next even whole number.  This is, in theory, the number of points to right shift.  In 

practice, a number slightly less than this may be required due to the finite length of the 

pulse and propagation delays in the instrument.  For the above values, we found that 38 

points rather than 40 points was optimum.  Enter the negative of this number as the Left 
Shift Points value in the processing parameter dialog.  In SpinWorks, a negative left 

shift is a right shift. 

3. Varian/Agilent data can be treated on the same way.  In one sample data set with a SW of 

5 MHz (DW = 100 ns) and an AD value of 4 µs (RD = 0) it was found that the optimum 

shift was 40 points (4 µs / 100 ns). Note that the AD and RD parameters exist only within 

the “SolidsPack” library. 

4. Set the linear prediction type (drop box) to Back Complex, and the Pred: value to the 

same number used for the right shift (positive this time!). 

5. Set the Coef: value to a fairly large number, 256 would be a typical value.  Values much 

larger than this make the calculation fairly slow. 

6. Set the Input: value to a fairly large value but, of course, no larger the TD value.  

Currently, SpinWorks limits this value to 1024.  If T2 is very short, you may be able to 

get away with a fairly small value, but it should be greater than or equal to the number of 

coefficients (Coef). 

7. Process the data.  The optimum right shift value is the one that gives the smallest first 

order phase correction. 

8. Adjust the Coef: and Input: values, if necessary, for optimum baseline. 

Thanks to Martine Monette at Bruker Canada for pointing this method out to me! 

Forward linear prediction has very little application in 1D NMR, but is used extensively in the 

indirect dimensions of multi-dimensional NMR experiments.  1D Forward LP is included in the 

1D routines of SpinWorks for instructional purposes, and for the rare time when the acquisition 

time must be cut short.  For the use of forward LP in two-dimensional spectra, please see the 2D 

section of this manual. 
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Figure 2.  LP parameters 

5.  Phasing Data 

After processing, the resulting spectrum usually must be phased.  The phasing mode is entered by 

clicking on the  button on the button panel. 

 

 

Figure 3.  Interactive Phasing Dialog 

A phasing dialog box will be displayed, and the zero-order reference point will be marked by an 

orange bar on the axis.  Adjust the zero order phase sliders to give a properly phased upright peak at 

the reference mark and adjust the first order sliders to phase the peaks that are furthest from the 

reference line.  Should a large first order correction be required, there are buttons to adjust ph1 in 

180 steps.  This should rarely be necessary in 1D spectroscopy of liquids, but may be useful in 

some solid state experiments.  If necessary, the spectrum may be zoomed or scrolled.  When you are 

satisfied with the phase of the spectrum, click on the Apply and Exit button.  Note that you can’t 

edit the values displayed in the ph0 and ph1 boxes – they simply display the values determined by 

the sliders.  If you want to manually enter phase constants, use the Edit Processing Parameters 
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dialog (Edit menu) or the Edit Pars button. 

Some spectra in JCAMP-DX format do not include the imaginary part of the data.  However, these 

data can still be phased by performing a Hilbert transform (Processing menu) on the data. 

6.  Baseline Correction 

For accurate integration or for other reasons, it may be necessary to apply a baseline correction to 

the data.  For most spectra you can simply use the Fully Automatic Baseline Correction function 

in the Processing menu.  There are some adjustable parameters that can be found in the Edit 

Processing Parameters dialog, but the default values are good for most cases.  The algorithm used 

(Whittaker smoother1) has a habit of treating very broad peaks as baseline, and large groups of 

closely clustered peaks may be overcorrected a tiny bit, with a slight negative baseline offset.  These 

problems can often be corrected by increasing the filter Lambda value (Processing Parameter 
dialog).  If you want to treat broad peaks as baseline (e.g. to remove probe background) then 

decrease the filter Lambda value.  You may need to reduce the lambda value by a factor of 1000 or 

more for the removal of broad peaks. 

If you need or want to define your own baseline points, click the  button on the button 

panel.  Then use the cursor to define at least 6 baseline points in the spectrum. Click the  

button to exit the BL Point mode.  Then, select Baseline Correction (Least Squares) in the 

processing menu.  A third order polynomial correction will then be applied to the data.  If necessary, 

the default correction parameters can be changed in the Processing Parameters...  dialog in the 
Edit menu.   

The polynomial is defined such that increasing curvature is to the right or low frequency (high field) 

end of the spectrum.  If your data has significant baseline curvature at the left end of the spectrum, 

simply reverse the spectrum, correct the baseline, and then reverse the spectrum to its correct 

orientation. 

A cubic spline baseline correction is also available with the Baseline Correction (Spline) 
selection. 

7.  Integration 

To integrate the spectrum, select the  button from the button panel.  A pop-up 

integration dialog box will appear on the screen.  The integration regions can then be selected by 

using the cursor to define the starting and ending points of the integral.  An integral can be deleted 

by selecting it with a single cursor and clicking the Delete Current button in the integration dialog.  

The integration can be calibrated by selecting an integral with the cursor (current integral trace 

changes to red), entering a calibration value into the box in the integration dialog (default is 1.0), 

and clicking on the integration dialog Calibrate button.  The integration traces can be scaled up and 

                                                 
1 P. H. C. Eilers, Anal. Chem. 75, 3631 (2003); J. C. Cobas et al., J. Magn. Reson. 183, 145 

(2006). 
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down independently of the spectrum scaling by using the appropriate buttons in the integration 

dialog.  Clicking Close in the integration dialog but will retain the defined integral regions. 

Integration regions are retained when reading a new data set.  This can be useful when it is 

necessary to integrate a series of spectra over the same region.  If this is not desired simply use the 

Delete All button of the integration dialog.  The integration regions are saved in a file with the data 

on disk, and can be read in if you wish to re-process the data with the same integration regions. 

It is possible to adjust the slope and bias of individual integrals, using the sliders on the integration 

dialog.  First select the integral with a left mouse click - the integral colour will become red to 

indicate that this is the current integral.  Then adjust the slope and bias with the sliders.  The 

sensitivity of the sliders can be adjusted with the + and – sensitivity buttons.  The integral can then 

be unselected by left-clicking or by selecting another integral.  The integration slope and bias values 

are saved in the integration regions file. 

However, adjusting the slope and bias on an integral can create a form of “confirmation bias” where 

you are adjusting the integral to the number you want, not what it actually is.  Properly phased 

spectra with good baselines rarely need any adjustment on the integrals.  Slope and bias adjustments 

should not normally be used to get “flat” integrals on overlapping peaks.  Band deconvolution is 

much better for this. 

SpinWorks 3.1 added the ability to integrate 2D spectra.  After selecting a region of the 2D file to 

integrate, it is necessary to click the Integrate button to add the region to the integrals list.  It is also 

possible to attach a label to the region by filling in the Label field before integrating the region.  2D 

integrals can be calibrated and deleted in the same fashion as 1D integrals. 

The integrals can be listed (in Notepad or whatever other program is associated with a .txt file) with 

the List button or an equivalent selection in the Peaks and Integrals menu. 
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Figure 4.  Integration dialog (1D and 2D) 

8.  Peak Picking 

Peak frequencies are picked with the Pick Peaks and Append to List selection in the Peaks and 

Integrals menu. The minimum intensity for peak picking can be set by clicking on the  

button on the button panel.  The desired minimum can be set by clicking in the data window.  A line 

will then be drawn at the selected height.  When the desired height has been selected, click the 

 button on the button panel. If desired, the peak picking minimum intensity can also be 

set in the Processing Parameters… dialog in the Edit menu.  This dialog can also be used to set 

the noise discrimination threshold for peak picking. Each peak pick appends to the current peak list.  

This enables one to pick certain regions of the spectrum and omit others.  The list may be cleared 

with the Clear Peak List selection of the Peaks and Integrals menu.  Specific peaks can be 

deleted with the Clear Peaks in Region selection. 

The number of digits displayed to the right of the decimal can be set from a dialog in the Peaks 
and Integrals menu. 

A text file list of frequencies may be generated with the List selection of the Peaks and Integrals 

menu.  This list may then be printed or saved to disk if desired.  The Units selection is used to 

choose between Hz. and PPM (default) for the peak display and print. 

The Interpolation selection is used to set whether the raw cursor frequency is used for the 
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calibration and assignment routines or whether an interpolated peak frequency is used.  The default 

is ON. 

The Sign sub-menu can be used to select whether peaks of both positive and negative intensity, 

only positive peaks, or only negative peaks should be displayed.  The default is for both intensities 

to be displayed. 

It is possible to manually add peaks to the peak list by clicking near a peak with the right mouse 

button.  If a peak matching the peak pick parameters (minimum intensity and noise threshold) is 

found near the cursor frequency, it is added to the peak list.  If no peak is found near the cursor 

frequency, the raw cursor frequency and intensity is added to the list.  This can be very useful if you 

want to add broad and/or noisy peaks to the peak list. 

The Calibrate selection is used to reference the spectrum.  Select the reference peak with the cursor 

(a red line will be displayed) and then use the Calibrate selection (or the  button on the 

button panel).  A dialog will then ask for the calibration frequency.  The value is entered in Hz. or 

PPM, depending on the currently used axis unit.  You can automatically select 0 or the chemical 

shifts of common solvents with buttons. 

For some applications (e.g. metabolomics) it is often convenient to divide the spectrum into a series 

of equally spaced bins, and then report the integrated, average or maximum value in that bin.  This 

can be accomplished with the Bin Data selection in the Peaks and Integrals menu.  The binned 

values will be listed, and can be edited or saved to a named file if desired.  The binning parameters 

(start and stop points, bin width, binning method) can be set in the Edit Binning Parameters… 
dialog available from the Edit menu.  The choices of binning methods are:  integral (sum over 

points in the bin), mean value of the bin, and the maximum value in the bin. 

9.  Printing 

Spectra are printed essentially as they are seen on the screen.  Integrals will be printed if defined.  

Peak frequencies will also be printed if peak picking has been done and Peaks and Match in the 

Options menu is turned on (default). Printing defaults to landscape orientation. The plot orientation 

can then be set to either portrait or landscape via the Page Setup… dialog in the File menu. This 

selection remains until changed or the program is exited.  Select Print Preview... in the File menu 

to confirm that the spectrum will print as desired.  The Print selection or the toolbar Print button is 

then used to print the spectrum. 

The Edit Plot Options and Parameters… selection in the Edit menu can be used to customize the 

plot.  You can select objects to be printed, colours, font sizes, etc. 

A plot title may be entered or edited with the Edit Plot Title… selection in the Edit menu.  The 

existing plot title as defined on the spectrometer will be read, and can be edited if desired.  This 

edited title is saved with any processed data. 

10.   Printing to a MetaFile 

The Copy to MetaFile… command in the Edit menu can be used to produce a copy of the 
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spectrum as it is set up to print as a Windows Enhanced MetaFile (*.emf).  This file can then be 

imported into Word (e.g. with Insert: Picture: From File), PowerPoint, etc.   This command opens 

up a file save dialog, allowing you to save the file to any desired folder.  The .emf extension will be 

automatically added to the file name.  The various objects to be included in the metafile can be set 

with the Edit Plot Options… selection in the Edit menu.    

Note that there are two options for saving to the Clipboard.  The first saves in a new .NET 

Clipboard format, which is unfortunately not understood by many other applications.  The second 

uses the older Win32 Clipboard format, which is fine for applications like Word and PowerPoint. 

Saving to the Win32 clipboard is not allowed in the Mono/Linux version.  The .NET clipboard may 

be supported under Linux, and printing to a Metafile works as expected in Linux. 
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Figure 5.  Spectrum imported into Word. 

JEOL Data 

Support for JEOL data is currently limited to 1D and 2D data in the so-called “jdf” format.  This 

format can be identified by the”. jdf”  file extension.  It is recommended that a separate folder be 

used for each single file data set.  For example, if you have a data set called brucine_1D1H.jdf, 

then put it in a folder called brucine_1D1H.  All of the ancillary files created by SpinWorks 

(processed data, integrals, simulation files, etc.) will then remain associated with the data.  (This 

is automatic with Bruker and Varian as these data sets are folders to begin with.) 

Recent JEOL and Tecmag spectrometers seem to be using digital filters similar to those used by 

Bruker.  That is, there is no compensation for filter group delay.  These data are characterized by 
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a “build-up” period at the beginning of the FID and spectra with extreme first order phase 

requirements.  SpinWorks should calculate the appropriate group delay and phase correction 

from parameters in the JEOL data set. 

However, if this does not work, here are two ways to process these data: 

1. In the interactive phasing mode click the ph1: +180 button repeatedly and take note of the 

oscillation in the baseline and the phase of the peaks.  You should see the frequency of the 

oscillation decrease and at some point the baseline will be flat and the peaks should all have 

nearly the same phase.  Then adjust the zero and first order phases until the spectrum is 

phased properly. 

2. The FID can also be left-shifted to compensate for the filter delay.  The left shift can be set in 

the 1D processing parameter dialog.  With the sample data that I have, a 20 point left shift 

was optimum. 

Note that the two methods do not produce identical results, although both methods are 

acceptable.  For Bruker Avance data, SpinWorks understands the characteristics of the digital 

filters and applies the necessary phase shift (as in method 1 above) automatically at the time of 

transform.   SpinWorks does not left shift Avance data, unless you want a left shift for some 

other reason.  Note that Bruker digital data must be converted to “analog” format (CONVDTA) 

in TopSpin) before left or right shifting in either SpinWorks or TopSpin. 

It is also possible to specify the group delay for a non-standard digital filter by specifying 

Custom DSP as the F2 Detection Mode in the Edit Processing Parameter Dialog.  The 

value for Group Delay can then be entered manually.  You can use this for JEOL and TECMAG 

data, or for older Bruker data with a non-standard DSP firmware version.  Recent Bruker data 

sets specify the group delay for all available digital filters, and SpinWorks automatically uses 

this value.  Most JEOL data seems to require either a group delay of 19.96, although some may 

require a group delay of 15. Note that sharper filters have higher group delays. Bruker digital 

filters are extremely sharp, with group delays on the order of 70 points. 

You can also correct for filter group delay with a circular left shift, although this procedure is 

mathematically identical to applying a first order phase shift.  Note that circular left shifting 

does not remove the “smilies” (or “frownies”) sometimes seem with this type of data, as has 

been claimed by others. 

There has been some discussion in various “blogs” of alternate methods of filter group delay 

correction, referring to these as “time correction” of the filter delay or “enhanced” correction.2  

While these methods do eliminate the “smilies”, they produce an overall baseline that is in fact 

much worse than that resulting from a simple first order phase correction.  With newer Bruker 

systems, using the “BASEOPT” digital filter results in a spectrum with a very flat baseline with 

virtually no DC offset, no “smilies”, and no first order phase correction other than that resulting 

from the group delay correction (360° × GRPDLY). 

                                                 
2 Examples would include Bruker’s “CONVDTA” command and mNova’s “enhanced” group 

delay correction. 
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Figure 6.  Digital filter group delay correction for JEOL data 
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Processing Arrayed Data 

Varian and Anasazi spectrometers can array parameters and produce an FID file which is 

actually a collection of FID blocks.  An example would be a T1 experiment where each τ value 

would be a different block.  To process arrayed experiments, select the fid file as you would with 

any other experiment.  If SpinWorks replies: “This appears to be 2D data, Switch to 2D mode?” 

click on No.  The first FID will be displayed, and you can process the data normally.  Each 

subsequent block can be automatically processed and displayed by clicking on the Prv and Nxt 
buttons on the button panel.  If the Phasing parameter (toolbar) is set to Last Constants, each 

block will be phased using the current phase constants. 

You also process and display an entire arrayed experiment with the Process Array selection in 

the Processing menu.  Each block will be processed and displayed in stacked display.  The first 

block will be the first stacked trace (in blue) while the active trace (in yellow) can be any of the 

arrayed traces.  You can select which of the stacked traces is the active trace with the Prv and 

Nxt buttons.  The cursor frequency and intensity, and the vertical scaling, refer to the “active” 

trace.  Display of active trace can be turned off by the appropriate selection in the View menu.  

Use the Edit Plot Options and Parameters… dialog (Edit menu) to turn off the active trace in 

the plot. 
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Figure 7.  Stacked trace display 

Properties such as scaling, offset and colours for the stacked traces can be adjusted with the 

Stacked Traces Properties dialog, available from the View menu.  The Rescale All to Main 
Trace button resets the scaling of all of the stacked traces to be equal to that of the experimental 

(main) trace. 
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Figure 8.  Stacked trace dialog 

Bruker arrayed (2D) data processing  

T1 and similar experiments from Bruker spectrometers are recorded as pseudo-2D experiments in 

a “ser” file.  These experiments can be processed with the following steps: 

1. Select the ser file just as you would for any other 2D file. 

2. Use the Edit Pars button (button panel) to check the processing parameters.  In particular, 

check that the window function in F2 is reasonable (Lorentz with appropriate LB parameter) 

and the size in F1 is bigger than the number of individual experiments or slices but not 

greatly larger.  In many cases you can use the minimum size of 64.  The chief problem here 

is that if you inherit an excessively large F1 size from the data set, the resulting processed 

data will be huge. 

3. Process the data with the Process Array (Bruker) selection in the Processing menu. 

4. The data will then be displayed in a stacked trace fashion.  The bottom (yellow) trace is 
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called the “active trace” and all 1D display manipulation is performed on this trace.  Above 

this is a stack (blue) of all the traces. You can make any of the stacked traces to be the active 

trace by using the Prv and Nxt buttons on the right hand button panel.  The trace number of 

the active trace will be displayed in the upper left hand corner of the screen.  Display of the 

active trace can be turned off, if desired, by unchecking the Show Spectrum setting in the 

View menu.  Use the Edit Plot Options and Parameters… dialog (Edit menu) to turn off 

the active trace in the plot. 

5. The offset, scaling, colour, etc. of the stacked traces can be adjusted with the Define 
Stacked Trace Properties… dialog, available from the View menu. 

6. You have three choices for baseline correction of arrayed data.  If you pick baseline points in 

the active trace, you can do either a polynomial or a spline correction of the entire array from 

the Processing menu (Least Squares Baseline Correct Array or Spline Baseline Correct 
Array).  Remember to click the red Return button to exit the baseline points mode before 

doing the actual baseline correction.  For certain spectra, you can also use the Auto 
Baseline Correct Array selection to baseline correct the data without defining the points.  

The fully automatic correction works well for spectra with sharp well-defined peaks (e.g. 13C 

spectra), and often does not do well with digitally filtered data that have a sharp curvature at 

each end of the spectrum. 

7. You can peak pick an array of spectra by placing a single cursor on top of a peak in the active 

trace and then using the Peak Pick Stacked Array selection in the Peak Pick menu.  If you 

use two cursors to define the left and right edges of a peak then this function will provide the 

area (integral) under the peak.  This can be useful for noisy spectra or broad peaks. 

8. The active trace can be integrated as any other 1D spectrum.  If you change the active trace 

with the Prv or Nxt buttons the integrals will reflect the new active trace.  After you have 

defined the integral regions in the active trace you can obtain a list of the relative integrals in 

all of the traces with the Integrate Stacked Array selection in the Processing menu.  These 

values are uncalibrated (raw) integral values.  The integrated values are listed in two formats:  

The first ordered by trace number and the second ordered by peak number. 

You can also process a consecutive series of Bruker “experiment numbers” in a similar fashion 

with the Process Series of ExNo (Bruker) selection.  An example would be a series of 1D 

NOE experiments. You can then transfer these spectra to the stack with the Copy Series of 
Bruker Experiment Numbers to Stack selection in the View menu. 

Deconvolution or Band Fitting 

Sometimes, it is desirable to fit or “deconvolute” overlapping peaks, in order to determine 

position, width and intensity.  SpinWorks has this feature included in the Simulation menu. Note 

that spectra to be deconvoluted should be well digitized and should have good baselines. 

Use the following steps to deconvolute a set of overlapping peaks: 

1. Define a set of starting values.  It is usually easiest to define the starting shifts by 

generating a peak list with the manual peak picking by right clicking on the location of 
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each suspected peak.  You can also use the regular peak pick command, but most peaks 

that you would want to deconvolute don’t peak pick very well. 

2. Transfer this peak list to a deconvolution list with the Copy Pick Peaks to 
Deconvolution List selection in the Simulation menu.  This will generate and display a 

synthetic spectrum based on the shifts and intensities of the peak list.  You can edit these 

values or add other peaks with the Edit Deconvolution Peak Parameters… selection 

in the Simulation menu.  At this point you will want to enter estimates for the peak 

widths as the initial list will have default values only.  Each parameter has a check box  

3. Start the Interactive Deconvolution Panel… from the Simulation menu.  In this panel, 

individual peak parameters can be adjusted with the + and – buttons, and can be 

optimized with the Optimize buttons.  The current RMS deviation between the simulated 

and calculated spectra is shown at the bottom of the dialog.  The Peak number box 

selects which peak to optimize. 

4. A global optimization of selected parameters can be performed with the Optimize button 

at the bottom of the dialog.  The actual parameters to be adjusted can be selected with 

check boxes in the Edit Deconvolution Peak Parameters… dialog.  Several rounds of 

optimization may be required for an optimum fit.  The fit is optimum when the RMS 

deviation is no longer changing significantly.  Note that the percentage of Gaussian 

character in the peaks cannot currently be globally optimized (it correlates very highly 

with the other parameters, baseline offset and phasing). 

5. The List button will provide a tabular output of the peak information and the Stack 

button can be used to copy the individual peaks to a stacked plot. 

6. The Rescale Display button sets the absolute scale of the simulated spectrum to be 

equal to that of the experimental spectrum. 

7. If desired, you can drag the vertical position of either the simulated or experimental 

spectrum to overlay the spectra.  Simply hold the left mouse button down on the zero 

position of either spectrum and drag it to the desired position. 

8. The Stack button can be used to display the individual peaks as stacked traces.  The 

properties of the stacked traces can de change with the Define Stacked Trace 
Properties… dialog in the View menu. 

9. You can use the Copy Simulated to Stack selection in the View menu to calculate the 

final simulated spectrum into the stack.  This makes for a neater display than displaying 

the simulated spectrum along with the stack.  You can then turn off display or printing of 

the simulated spectrum. 

10. The Dump button can be used to dump the simulated spectrum as well as any stacked 

traces to X,Y data files.  These files will be located in the same folder as the fid file. 
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Figure 9. This dialog can be used to enter or edit peaks for deconvolution. 
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Figure 10. Dialog that can be used to interactively adjust the deconvolution parameters. 
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Figure 11. Deconvolution of Phosphinamide ligand (13C MAS) 
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2D Processing 

Introduction to 2D Processing 

SpinWorks has the capability to process 2D data sets from UNIX/Linux and Windows based 

Bruker (A?X and Avance), UNIX/Linux based Varian/Agilent (DDR, DDR2, VNMRs, Inova, 

Unity, Mercury, Gemini), JEOL and Anasazi  spectrometers. Provision has been made for 

Hypercomplex (States, States-TPPI, echo-antiecho), TPPI and Magnitude mode data. Every 

attempt has been made to make the 2D mode of SpinWorks as consistent as possible with the 1D 

mode.  SpinWorks also tries to set processing parameters and modes that are appropriate for the 

data, resulting in very easy processing.  However, inappropriate parameters (e.g. referencing, 

detection mode, etc.) may be inherited from the original data.  In these rare cases, the parameters 

can be overwritten in SpinWorks. 

Selecting the 2D Data Set 

SpinWorks should automatically detect Varian, Bruker, JEOL and Anasazi data formats, and can 

distinguish between 1D and 2D data.  However, should this not work for some reason, you can 

use the Options menu set the Data Format according to the brand of spectrometer that you are 

using  and also set the 2D selection.   

In order to read processed data from the NMRPIPE program, select NMRPipe Processed Data 

from the Data Format sub-menu of the Options menu. 

In the File menu, use the Open… command or the recent files list to select the appropriate raw 

spectral data.  Select the ser file for Bruker data, the fid file for Varian data, and the .jdf file for 

JEOL data..  If you use the Open command, you will have to navigate through the directory tree 

to the correct file.  Bruker data sets have the structure: …/exname/ex#/ser while Varian data 

sets have the structure: …/exname.fid/fid.  When you are transferring data make sure that you 

transfer the entire data set, as SpinWorks requires information from the various parameter sets 

that are stored with the raw FID data (the procpar, acqus, procs, proc, title, etc. files).   

You can use the Set Preferences selection in the Options menu to set the default data directory 

for the File Open… dialog. 

After the data set has been opened, the first FID (first t1 value) will be displayed on the screen.  

You can step through the individual FIDs with the Prev and Nxt buttons. 

Setting the 2D Processing Parameters 

SpinWorks gets most of the necessary processing parameters from the parameter files of the data 

set.  If you want to override these, or to simply check on the parameters, you can use the 2D 
Processing Parameters… selection in the Edit menu or the corresponding green Edit Pars 

button on the button panel.  Separate panes are available for the detection (F2) dimension and the 

evolution (F1) dimension.  The following parameters can be edited: 
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Size    

The number of complex data points in each dimension.  This value must be a power of 2, 

and will be rounded up to the nearest power of 2 if it isn’t. 

Frequency of 0 ppm    

The value (in MHz) used as the calibration reference point in the spectrum and is 

equivalent to the Bruker SF parameter.  If the data were properly calibrated on the 

spectrometer, then this value should not need to be changed.  Referencing can also be 

accomplished (more conveniently) with the Cal button on the toolbar. 

Detection Mode   

For F1, this checkbox specifies whether the data were recorded in single (magnitude or 

Bruker QF mode) TPPI, States, States-TPPI or echo-antiecho, mode.  SpinWorks can 

normally determine this from the data set parameters.  The sequential setting is not 

currently used.  Note that the Varian gHSQC sequence uses echo-antiecho, and sequences 

that the Varian documentation specifies as States-TPPI, processes in SpinWorks as 

States.  The necessary correction to convert the data to States format has been applied at 

the spectrometer.  For Varian data, the F1 detection mode is determined from the “f1coef” 

and “phase” parameters. 

The Varian gHMBCAD experiment requires echo-anti-echo. 

Determining the F1 detection mode for JEOL data is still a bit problematic.  SpinWorks 

tries to guess at the detection mode, but you may have to experiment.  COSY and HMBC 

like experiments will probably use the COSY/HMBC setting, HSQC like experiments 

will probably use Echo-Antiecho, and NOESY will probably use States. 

The F2 detection mode is can be one of Simultaneous, Sequential or DSP, and is 

normally determined correctly from the acquisition parameters. 

Reverse      

Check this box if you find that the F1 direction needs to be reversed.  This is pulse 

sequence and spectrometer model dependent.  SpinWorks should set this correctly for 

most data sets.  An exception seems to be magnitude mode data (e.g. COSY and HMBC) 

from Bruker AMX spectrometers.  Data from Avance series spectrometers should be 

O.K.  Using the F3 (a.k.a. Y or decoupler B) channel for HSQC type experiments on an 

AMX spectrometer may also result in a reversed F1 dimension.   

Data from JEOL spectrometers may require F1 reversal, depending on the experiment. 

Reversing F2 should never be necessary. 

First Point Correction    

Applies a multiplier to the first point of the FID.  The default value of 0.5 is good for the 

vast majority of data sets.  Experiment with the value if you need to remove some 

baseline offset in the transformed spectra.  An alternative is to apply drift correction (2D 
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Processing sub-menu) after processing. 

Bias Corr.    

Determines whether a DC offset or bias correction should be applied to the FID.  The 

default value is OFF, and it should only be turned on if there is a noticeable zero 

frequency “spike” at the centre of the spectrum.  This is very unusual in modern 

spectrometers. 

Window Function    

This is the pre-transform apodization function applied to the data.  Choices are: none, 

Lorentz, Lorentz to Gauss (the Bruker “GM” function), Sine, Sine Squared, TRAF, 

TRAFS and Gaussian.  Details of the TRAF and TRAFS functions can be found in the 

1D processing section.  The shift parameter is the shift (in degrees) for the Sine and Sine 

squared function, while the LB and GB parameters are used by the Lorenz, Lorentz to 

Gauss, TRAF, TRAFS and Gaussian functions.  Note that the Lorentz to Gauss 

selection uses the LB and GB parameters, while the Gaussian Selection uses LB only. 

For Bruker data, the window function and parameters specified on the spectrometer will 

be used. For Varian data, SpinWorks currently selects window function parameters based 

on the detection mode and pulse sequence name (if a standard Varian pulse sequence was 

used).  The reason for this is that the window function definition and parameters used in 

SpinWorks differ significantly from those used by VNMR.  Future versions will 

hopefully select the window function and parameters based on the values set in the 

spectral parameters. 

Linear Prediction    

Specifies the parameters used for linear prediction of the data set.  This is typically only 

used in the indirect dimensions where the number of time domain data points is small.  

You can specify the number of points to be predicted, the number of coefficients, the 

number of input points used for prediction, and whether you want forward or reverse 

prediction.  Only forward prediction is supported in F1, while only backwards prediction 

is supported in F2.  These parameters may require some experimentation, but the default 

values are usually satisfactory.  You can usually double the number of time domain data 

points in the indirect dimensions, and the number of coefficients will typically be 8 to 16.  

The number of Input Points can usually be set to the one half the number of time domain 

points in T1, which is the default value. If you get what appears to be streaking in F1, you 

can increase the number of input points and/or the number of coefficients.  The Cutoff 
value can be left at the default value for most cases, but raising it can speed up the LP 

procedure. 

The newest LP addition is the Zhu-Bax “forward-backward” algorithm (J. Magn. Reson. 

100, 202 (1992)).  This routine seems better than the others, and can extrapolate the data 

further than the others.  For example, extrapolation from 128 to 512 points is possible for 

data with a good signal to noise ratio.  It is not recommended to raise the number of 

coefficients above 16, and the input points parameter is not used for this algorithm (the 
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whole data set is used).  Future releases of SpinWorks may have this as the standard or 

default LP algorithm. 

Note: In most cases simply selecting Forward or Zhu-Bax and leaving all of the other 

parameters at their default values will provide the best results. 

Note:  Linear prediction works well when an indirect dimension has been abbreviated in 

order to save experiment time.  Applying linear prediction to a data set that has already 

decayed to the noise will not provide any improvement in resolution, and will likely 

result in poorer sensitivity.  

For F2 (the detection or acquisition dimension) it is always better to increase the 

resolution by increasing the acquisition time (narrowing SW or increasing TD or NP) 

rather than by relying on linear prediction.  This does not increase the experiment time, as 

the increase in acquisition time can be compensated by a reduction in the relaxation 

delay. The only time when this may not be appropriate is when there is severe decoupler 

heating during acquisition. 

Phasing    

Specifies the type of phase correction to be applied to the data during the transform.  

Possible values are: none (you will phase the data interactively later) constants (the 

specified zero and first order corrections will be applied to the data during transform), 

magnitude (appropriate for the F1 dimension for magnitude COSY and HMBC) and 

power.  Note that applying magnitude or power spectrum processing to the detection 

dimension (F2) would be pretty silly. 

HOGWASH  (F1 only) parameters.   

These are described separately in the HOGWASH section of this manual.  

Solvent Filter  (F2 only)  

This provides a high-pass filter for removing a strong solvent signal (e.g. H2O) from the 

centre of the spectrum.  Gauss or Sine usually work best, and the number of points 

determines the selectivity of the filter.  A larger number of points creates a narrower 

filter, with the default value giving good results for typical proton 2D spectra recorded in 

water.  However, you should experiment to achieve the best result.  Note that solvent 

filtering is purely cosmetic and does nothing to actually improve the dynamic range or 

baseline of the original data. 

F1 Ref Freq   (F1 only)   

Specifies the frequency to be used for Hz to ppm conversion in the F1 dimension.  

Buttons are available for the Observe transmitter, Decoupler or Decoupler 2.  The 

frequency can also be entered manually.  These buttons are most often used to correct bad 

“refsource1” or “refsource2” parameters in Varian data sets. 
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Figure 12.  F2 (and 1D) processing parameter page 
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Figure 13.  2D F1 processing parameter page 

Processing 2D Data 

Transform  

Once you have selected your 2D data and have set the processing parameters, you will need to 

process it.  In 2D mode the green Process buttons on the button panel will process the data as 
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specified by the current processing parameters. Although you can process the F2 and F1 

dimensions separately, it is usually easiest to click in the Proc. Both button to do a complete 

transform of the data.  For 2D data sets that do not require phasing (e.g. COSY, HMBC and 

HETCOR), clicking the Both button may be the only processing that the data set requires.  This 

will be true if appropriate window functions and other processing parameters were set up 

correctly at the time of acquisition.  (For experiments run with IconNMR or with the standard 

parameter sets, this will always be so.) 

2D MQ MAS spectra require a special type of transform called a “shearing transform,” in which 

a T1 dependent first order phase correction is applied to each row of the spectrum after the first 

(T2) transform.  The phase constant or “shearing angle” depends on the spin of the nucleus and 

the quantum selection of the experiment.  The angle can be calculated with the MQ MAS 
Toolbox… dialog available in the 2D Processing sub-menu of the Processing menu.  A 

particular angle can also be entered, if desired. 

 

Figure 14.  MQMAS shearing transform dialog 

The referencing buttons adjust the referencing so that each of the dimensions can be referenced 

to the transmitter, if desired.  The Calculate button is used to calculate the required shearing 

angle after the Spin and Quantum values have been set. 

The shearing transform for MQMAS data has only been tested on Varian data.  Testing with 

Bruker data is still required. 

Note that the scaling of the F1 axis retains the scaling of the original unsheared data.  There are 

several conventions for the scaling and referencing of MQMAS data, and there does not seem to 

be a consensus as to which one is best.  Consult: 

Y. Millot and P. P. Man, Solid State Nuclear Magnetic Resonance, 21 21-43 (2002) and other 
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solid state NMR literature for a detailed discussion. 

Some other less frequently used 2D processing commands are also found in the 2D Processing 

sub menu of the Processing menu. 

2D Display 

The default mode for the 2D display is “image” mode where both the positive and negative 

intensities will be displayed.  For magnitude data and phased phase sensitive data, a Pos Only 

mode can be selected from the Button Panel.  It is also possible to display the data in a “contour” 

mode and to select coarse or fine contour spacing.  The lowest displayed contour and the highest 

displayed contour can be adjusted with the floor and range buttons.  Note that  -   means moving 

the floor level down, or closer to the noise.  Therefore click the  -  button to see smaller peaks.  

Similarly, moving the range up or down will control the number of levels displayed.  As a 

starting point, set the floor just above the noise (or artifact) level and adjust the range so that the 

highest peaks are displayed in the most intense colours.  For spectra with very large dynamic 

range, lowering the range even further will give more contours on the smaller peaks at the 

expense of the more intense peaks.  The normal contour level spacing is logarithmic, but may be 

changed to linear spacing with the appropriate selection in the View menu. 

Note that buttons that toggle between modes display what the action of the button will be, not 

the current state.  For example, if the button is labeled Contour, clicking it will switch from 

image mode to contour mode. 

In image mode, all levels below the “floor” will be black, while all levels above the range or 

ceiling will be displayed in the colour of the highest level. 

The “image” display mode is considerably faster than the contour mode.  Printing is always done 

in contour mode, irrespective of the display setting. 

Figure 15.  2D display buttons 
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Clicking the left mouse button with the cursor in the data area will cause a set of red cross-hair 

lines to be drawn.  Clicking again will cause a second set of lines to be drawn, and will thus 

define a region.  This region can be zoomed by clicking the middle mouse button (if available) or 

the blue Zoom button.  The cross-hair lines can be erased by clicking the left mouse button a 

third time. 

Individual rows or columns of the 2D matrix can be selected and displayed with clicks of the 

right mouse button.  The selection of Row Mode or Col Mode determines which will be 

displayed.  Switching to 1D Display mode will transfer the last highlighted row to the 1D 

display.  You can examine and plot individual 2D rows in this manner, using all of the 1D tools 

of SpinWorks.  You can select which of the rows is highlighted (in yellow) by selecting it with 

the toolbar up and down arrows. Currently (version 3.0), columns cannot be transferred to the 1D 

display mode.  However, columns can be saved as JCAMP-DX files (see below), and then read 

as 1D spectra. 

Rows or columns selected with the right mouse button can be saved as JCAMP_DX files by 

using the Save Displayed Columns or Save Displayed Rows selections in the File menu.  

These spectra will be saved with names like row482.dx in the folder containing the folder 

containing the current raw data.  The titles in these files will have the chemical shift of the 

extracted row or column attached.  These rows and columns can then be read by SpinWorks in 

1D mode, but be sure to set the data type to JCAMP-DX first. 

When extracted rows or columns are displayed on the screen, one will be highlighted in yellow, 

while the others will be displayed in blue-green.  The highlighted trace is one to which vertical 

amplitude scaling will be applied (Scale: + and – buttons).  The currently active trace can be 

changed with the button panel Prv and Nxt buttons. 

Hint: If you have sufficient memory in your computer, you can start a second (or third) copy of 

SpinWorks for examination and printing of the extracted rows and columns.  This allows you to 

keep the 2D data in the first copy. 

A cross-hairs cursor can be displayed on the screen by using the tracking cursor selection in the 

View menu.  You can use the keyboard “t” key as a shortcut to toggle the cross-hairs on or off.  

“Double clicking” will also toggle the cross-hair cursor.  Spectra can be displayed and printed 

with the F1 axis horizontal by using the Rotate 2D selection in the View menu.  Note that 

interactive phasing requires that F2 axis be horizontal.  Spectra can be rotated to the desired 

format after phasing, of course. 

Phasing 

2D data may be phased in several ways: 

 Phase constants set in the 2D Processing Parameters dialog (Edit menu) can be 

applied at the time of transform.  It the data have been previously phased with XwinNMR 

or VNMR, the phase constants read in with the data should work in SpinWorks. 

 Phase constants set in the 2D Processing Parameters dialog (Edit menu) can be 

applied after the transform.  This is accomplished with the F2 (det.) F1 (evol.) or 
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Magnitude buttons in the Phasing section of the 2D Processing dialog. 

 The first increment FID can be transformed and phased to give the F2 (acquisition 

dimension) phase constants.  Note that this method will not work for experiments that 

have zero intensity in the first increment.  For example, some phase sensitive COSY 

experiments. 

 The 2D spectra can also be phased interactively.  The method is essentially the same as 

used in 1D mode.  Note that the spectra must be in the normal (to me) “F2 horizontal” 

mode for interactive phasing.  Use the View menu to turn the Rotate 2D option off if 

necessary.  Spectra can be rotated to the “F1 horizontal” mode after phasing, if desired. 

To phase spectra interactively: 

1. Select either the row mode or column mode in from the button panel.   

2. Select rows or columns that contain peaks in diverse regions of the spectrum by 

clicking on the peak with the right mouse button.  The extracted row will be displayed 

on the screen.  The amplitude of the extracted traces can be changed with the Scale: 
+ or – buttons on the button panel.  The highlighted trace only will be changed.  

Which trace is highlighted can be changed with the Prv and Nxt buttons. 

3. Select the peak to be used as the pivot point (the point where the first order phase is 

always zero) by marking it with the left mouse button. 

4. Use the phase button on the toolbar to start the interactive phasing routine.  Adjust the 

zero order phase (ph0) on the selected pivot peak (it should be marked with a green 

line) and adjust the first order phase (ph1) on the other peaks.  Note that in column 

mode, positive is to the right.  When satisfied with the phase, click on the Apply and 
Exit button. 

5. Now phase the other dimension, if required.   

Note that most Varian pulse sequences are written so that the F1 phase correction is zero (or very 

close to zero).  In such cases no F1 phase correction is usually required. However, due to 

differences in processing algorithms, some (usually echo-antiecho) data that have zero F1 phase 

correction in VNMR may require exactly a 90 degree correction in SpinWorks.  SpinWorks can 

recognize some of these sequences and set the phasing constant appropriately.   

Many Bruker experiments calculate the F1 phasing based on the delays and pulse lengths in the 

sequence.  These phase constants will work in SpinWorks with the F1 phasing set to Constants. 

Data from newer Avance spectrometers usually don’t require F1 phasing. 

For NMRPIPE data, the imaginary parts of the spectra are not normally stored with the data.  In 

this case, use the F2 and F1 Hilbert transform function available in the 2D sub-menu of the 

Processing menu. 

Baseline Correction 

2D spectra in organic solvents rarely require baseline correction.  However, if baseline correction 

is required, it can be applied to either dimension with the Baseline Correct F2 or Baseline 
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Correct F1 selections of the 2D Processing sub-menu of the Processing menu.  A Whittiker 

smoother algorithm is used.  The default parameters are usually good, but can be adjusted in the 

processing parameter dialog if necessary. 

If the baseline is offset or sloped, but not very curved, it may be better to use “drift correction” 

instead of baseline correction.  This corrects any slope and bias in the baseline, and will be 

familiar to VNMR users.  The drift correction commands are also in the 2D Processing sub-

menu of the Processing menu.  

Note that the first point correction value (2D Processing Parameters dialog) will also affect 

the DC offset of the spectrum. 

F2 and F1 Reference Spectra 

Processed 1D reference spectra can be displayed and printed along the F2 and F1 dimensions. 

 Process the 1D data normally and save the processed spectra as JCAMP-DX files (File 

menu). 

 After processing your 2D data, use the Read F1 Trace… or Read F2 Trace… buttons in 

the File menu to read in the JCAMP-DX files as "projections." 

 The vertical scaling can be adjusted by clicking near the 1D projection and using the Scale: 
+ and - buttons, and the individual traces can be turned on or off with the drop-down menus 

on the tool-bar.  The F1 and F2 reference spectra can also be scaled by placing the cursor near 

the appropriate 1D spectrum and using the mouse wheel (if you have one). 

 Note that the 1D reference spectra do not have to have been recorded with the same SW as 

the 2D spectrum.  They should normally be recorded at the same field.  However, there is 

now a Convert Field function (Processing menu) which can be used if you want to use a 

1D reference spectrum recorded at a different field. 

Projections 

As an alternative to displaying external 1D spectra along the edges of a 2D spectrum, it is also 

possible to display projections of the 2D data.  This can be very useful for a dimension where a 

1D reference spectrum cannot be recorded.  An example would be the 13C dimension of HSQC, 

HMQC and HMBC type experiments.  For these experiments, data can often be obtained for 

samples that are too dilute for conventional 13C spectroscopy.  The projections can be calculated 

and displayed with the F1 and F2 trace drop-down boxes on the toolbar.  The projections can be 

scaled by placing the cursor near the appropriate 1D spectrum and using the mouse wheel (if you 

have one), or by clicking near the projections and using the Scale: + and – buttons on the button 

panel.  The projections can also be calculated with the appropriate selection in the Processing 

Menu (2D sub-menu). 

When the projections are generated, copies are also saved in the current data folder as JCAMP-

DX files.  These have the names f1_proj.dx and f2_proj.dx, and can be read by SpinWorks in 1D 

(JCAMP-DX) mode.  They can then be peak picked, printed, etc. just as for normal 1D spectra. 
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F2 and F1 Traces (Scanning) 

Interactive scanning of F2 and F1 traces can be displayed by clicking the F2 Scan and/or the F1 
Scan check boxes.  The cross-hair cursor will also be turned on, in order to make it easier to see 

where the trace is being extracted. 

F1 Referencing 

In a perfect world, spectrometer manufacturers would provide parameter sets for all of the 

common 2D sequences with correct referencing information in F1.  Failing this, the facility staff 

should set up the referencing information.  Alas, the real world seems to be quite different.  

Bruker data recorded with standard parameter sets, especially if recorded with ICONNMR, seem 

to be reasonably good.  Varian data sets seem to be much poorer, especially for indirectly 

detected heteronuclear correlation experiments (HSQC, HMBC, etc.)  Homegrown parameter 

sets may or may not have correct referencing information.  

A problem that often occurs with Varian data is an incorrect “refsource1” parameter.  This 

specifies the channel that is used for Hz to ppm conversion in evolution dimension.  For 

experiments like HSQC, gHSQC, gHMBC, etc. this parameter needs to be set to “dfrq”, but quite 

often is set to “sfrq”.  Likewise, some BioPack sequences such as gNhmqc have “refsource1” set 

to “sfrq” whereas in this case is should usually be “dfrq2”.  To correct problems with F1 channel 

selection, the F1(evolution) panel of  2D Processing Parameters dialog has buttons to set the 

channel used for Hz to ppm conversion in F1.  In the Special Cases group box, there are 

buttons to set the F1 channel to the observer transmitter, the decoupler or the second decoupler.  

The frequency can also be entered manually into the edit box, but this should rarely, if ever, be 

required. 

Once it is certain that F1 is using the correct frequency for Hz to ppm calculations, it may be 

necessary to set the actual reference position.  With properly edited parameter sets (on the 

spectrometer end) this value is usually pretty good, but is rarely perfect due to differences in 

concentration, temperature, solvent, etc.  There are several ways that calibration of the indirect 

(F1) dimension can be accomplished: 

1. If the shift of a peak is known (usually from a 1D spectrum) then the yellow Calibrate 

button (button panel) can be used to set a peak to a known shift value.  Simply select the 

desired peak with the cursor, click the Calibrate button and then enter the correct shifts in 

the dialog box. 

2. If the absolute frequency of 0 ppm is known, it can be entered into the appropriate box in the 

F1 page of the 2D Processing Parameters dialog.  This value can usually be seen on 1D 

plots produced by SpinWorks, XwinNMR or TopSpin (SF parameter).  If this value is not 

available for your particular sample, (often because you haven’t run a carbon spectrum) then 

the value from another sample in the same solvent at the same temperature will be very close. 

3. An automatic referencing of F1 for many solvents can be accomplished using the Auto 
Reference F1 sub menu in the Processing menu. Select the F1 nucleus and solvent 

appropriate to your data.  This procedure assumes that the F2 dimension is proton, and has 

been correctly referenced.  The reference values used are valid for dilute solutions at 25C.  



  

SPINWORKS 4.1 MANUAL 53 

 

The homonuclear option will set the referencing in F1 to be the same as that in F2. 

Note that even if the referencing in the 2D spectrum is identical to that in the 1D spectrum, there 

may not be perfect alignment between the two in some experiments.  There are two reasons for 

this.  In the F2 dimension of an HSQC or HMBC type experiment (or F1 of a HETCOR or 

COLOC experiment), the observed signals are due to the 13C isotopomer, while what is observed 

in the 1D proton experiment is the 12C isotopomer.  There is an isotope shift between the two, 

which becomes more noticeable at higher fields.  The second reason for a misregistration of 

peaks between 1D and 2D experiments is due to the sample heating which may occur from X 

nucleus decoupling.  This effect is most noticeable in solvents where the lock shift is temperature 

dependent, usually D2O.  Adequate cooling air and newer low power (adiabatic) decoupling 

sequences can reduce this effect. 

Remember, though, that with decent parameter sets on the spectrometer, manual adjustment of 

the F1 referencing should only be required in special circumstances.  E.g. different temperature 

or pH, odd solvent, etc. 

2D Integration  

2D Spectra can be integrated with the same dialog used for 1D integration.  However, the 

method used to define the integrals, though, is slightly different.  After defining a region to be 

integrated with two cross-hair cursors, it is necessary to click on the Integrate button to generate 

the integral.  You can also define a label for the integral by entering text into the Label box 

before clicking the integrate button. 

Dual 2D Display 

It is possible to display two 2D spectra in a side-by-side dual display fashion.  The left hand 

spectrum corresponds to the current workspace, and the right hand spectrum is a processed 2D 

“imported” from another workspace.  The two data sets do not have to have identical spectral 

widths or sizes, but at least part of the chemical shift ranges of the two data sets must overlap.  

All display manipulation and processing commands work on the current workspace. That is, the 

left hand data set.  The display limits of the right hand data set will be automatically adjusted to 

match the current workspace values.  The following method can be used to display two data sets: 

1. Select a workspace and then select and process a 2D data set in the normal fashion. 

2. Move to another workspace.  Select and process another 2D data set.  Set an appropriate 

contour threshold, colour mapping, etc. 

3. Return to the original workspace of step 1. 

4. In the View menu use the Dual Display of Workspace sub-menu to choose the 

workspace with the second data set.  The frequency limits of this second data set will 

match those of the first.  If you zoom or expand in the first data set the display limits of 

the second data set will be adjusted to match. 

5. If you need to adjust the contouring levels in the second data set you must switch to the 

second data set, make the necessary adjustments, return to the first data set, and then use 
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the Dual 2D Display of Workspace sub-menu again. 

 

 

Figure 16.  Dual 2D display of Cyclosporine A with the COSY spectrum on the left and the 

TOCSY spectrum on the right. 

2D Peak Assignment Tool (under construction) 

When solving a structure, it is often useful to use the HSQC or HMQC spectrum as a 

“worksheet” and use combined COSY, TOCSY, NOESY and HMBC in conjunction with the 

HSQC data in order to piece together the carbon framework of the molecule.  SpinWorks has a 

notebook tool that allows you to keep track of these peak assignments.  Although this tool would 

typically be used with a CH correlation (HSQC, HMQC or HETCOR) spectrum it could, in 

principle, be used with any 2D spectrum.  The peak assignment tool is used as follows: 

1. Click on the Row/Col/Label button (button panel) in order to get to the peal labeling 

mode. 
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2. The right mouse button can now be used to label cross-peaks.  Information on COSY, 

TOCSY, NOESY and HMBC correlations to this peak can then be entered or edited. 

3. The compiled assignments can be listed with the List function in the Peak Pick menu. 

 

Figure 17.  2D Label and assignment tool. 

2D Processing Tutorial 

A number of 2D data sets are available for download, and contain data acquired on both Varian 

and Bruker spectrometers, with a number of detection modes. 
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Magnitude (COSY and HMBC type) Data 

COSY data sets are usually processed with unshifted sine window functions in F1 and F2, 

magnitude phase correction in F1 (only!) and "COSY/HMBC" type detection mode.  It should 

not be necessary to specify whether the data are Varian, Bruker, JEOL or Anasazi as the program 

can identify the data format automatically.  It should also automatically determine whether the 

data are 1D or 2D.  For Varian data, a confirmation question will be asked before switching to 

2D mode. 

1. Use the File Open command to navigate through the supplied sample data and select either 

the …gCOSY.fid/fid Varian file or the …cosy_qf/3/ser Bruker file.  After selecting the file, 

the first block (FID) of the 2D data set will be displayed.  If these data sets are not available, 

any Bruker or Varian COSY, gCOSY or HMBC type data set could be used.  Note that 

Varian gHMBCAD experiment, however, requires echo anti-echo as the F1 detection 

mode. 

2. Use the Edit 2D Processing Parameters… selection in the Edit menu or  on 

the button panel to examine the 2D processing parameters.  With the supplied sample data, 

these will all be correct, and are typical of what would be used for a magnitude COSY 

spectrum. Note that for Bruker data the processing parameters are read from the data set.  If 

the data set was set up correctly on the spectrometer, it should process on SpinWorks without 

any adjustment of the processing parameters.  For Varian data, the default processing 

parameters are based on the name of the pulse sequence, the “f1coef” parameter and the 

“phase” parameter.  If SpinWorks recognizes the pulse sequence, it should default to 

reasonable parameters.  If SpinWorks doesn't recognize the pulse sequence, then you may 

have to set some processing parameters yourself.  Note that the COSY type parameters are 

also suitable for HMBC spectra. However, the window functions should be changed to sine 

or sine squared with a 45 to 90 degree shift. 

3. Process the data in both dimensions by clicking the  on the button panel.   The 

status of the transform will be displayed at the bottom of the screen, and when finished an 

image mode 2D spectrum will be displayed on the screen.  This can be changed to contour 

mode by selecting  on the button panel.  Note that the current contouring 

algorithm in SpinWorks can be a bit slow on some machines.  Since this is magnitude mode 

data, mapping negative levels doesn't make any sense.  Therefore, select the  

button to display the positive contours in a more complete set of colours.  The floor (lowest 

contour) and range (highest contour) can be changed with the appropriate buttons. 

4. Clicking the left mouse button in the data window will mark the point with a set of red cross-

hair cursors.  Clicking the left mouse button in the data window a second time will define a 

region that can be zoomed with the  button or by clicking the middle mouse 

button.  Clicking the left mouse button in the data window a third time will erase the cursors. 

5. Use the Edit 2D Processing Parameters… selection in the Edit menu to set F1 linear 
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prediction to Zhu-Bax, the number of coefficients to 16 and the number of predicted points 

to 512.  Exit the dialog by clicking the O.K. button.  In the 2D Processing and Display 

dialog, click the Both button to re-process the data.  You should see a significant 

improvement in the resolution in the F1 dimension. 

6. Print and Print Preview in the File menu work as expected. 

7. If you wish to apply baseline correction or symmetrize the data, these functions are available 

in the Processing menu. 

 

Figure 18  COSY spectrum on an Avance 300 processed with Zhu-Bax linear prediction. 

Phase Sensitive (HSQC type) Spectra 

There are several ways in which phase sensitive 2D data can be recorded.  The data can be 

purely hypercomplex (two FIDs recorded 90 out of phase, but with the same t1 value - often 

known as the States method), TPPI (t1 and phase incremented at the same time), a hybrid called 

States-TPPI, or the echo-antiecho method, which applies to certain types of gradient 

experiments.  SpinWorks must know how the data were recorded in order to process it correctly.   
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For Bruker data, this information is obtained from the processing parameters in the data set. Data 

recorded with standard Bruker parameter sets (e.g. in IconNMR) will almost always have correct 

processing parameters.   Parameter sets created by users may, however, be incorrect.  Most phase 

sensitive Bruker pulse sequences use TPPI, although we commonly use an echo-antiecho HSQC. 

The comments included with each Bruker pulse sequence usually indicate the detection mode 

used. 

Note that the F1 phasing can be calculated, and does not change unless you change the F1 spectral 

width. On the supplied Bruker data, the F1 phase constants (as calculated by XwinNMR or set up 

in the parameter set) should do a good job of phasing F1 if you tell SpinWorks to apply phasing 

during the transform. (Edit 2D Processing Parameters…   F1 (evolution)   Phasing   

Constants).   

It is also possible to adjust the timings in a pulse sequence so that there is no required F1 phase 

correction.  This approach is seen in most Varian data and data from newer Bruker Avance 

systems, although a little phasing in F1 can be useful. 

For Varian data, SpinWorks guesses the F1 detection mode from the name of the pulse sequence. 

If the pulse sequence name is not recognized by SpinWorks, SpinWorks then uses the “f1coef” 

and “phase” parameters. If the “f1coef” parameter is null or not recognized, SpinWorks will 

assume either COSY type or States type data, depending on the “phase” parameter. Most phase 

sensitive Varian pulse sequences are either hypercomplex (States) detection (e.g. HSQC, 

TOCSY, NOESY) or echo-antiecho (e.g. gHSQC).  Some sequences in BioPack or ProteinPack 

are written as States-TPPI, but the data seem to be converted to pure hypercomplex (States) 

when the data are stored to disk.  These data sets can be processed exactly like States data.   

1. Use the File Open command to navigate through the supplied sample data and select either 

the …HSQC.fid/fid Varian file or the …hsqc_av300/2/ser Bruker file.  After selecting the 

file, the first block (fid) of the 2D data set will be displayed.  If these data sets are not 

available, any Bruker or Varian HSQC, gHSQC or HMQC type data set should work. 

2. Use the Edit 2D Processing Parameters… selection in the Edit menu to examine the 2D 

processing parameters.  With the supplied sample data, these will all be correct, and are 

typical of what would be used for an HSQC spectrum. Note that for Bruker data, the 

processing parameters are read from the data set.  If the data set was set up correctly on the 

spectrometer, it should process on SpinWorks without any adjustment of the processing 

parameters.  For Varian data, the default processing parameters are based on the name of the 

pulse sequence.  If SpinWorks recognizes the pulse sequence name, it should default to 

reasonable parameters.  If SpinWorks doesn't recognize the pulse sequence, then you will 

have to set the processing parameters yourself.  With some data sets, it may also be necessary 

to optimize the Windowing parameters for optimum signal to noise ratio. 

3. Close the Edit 2D Processing Parameters… dialog and click  on the button 

bar to process the data in both dimensions.   

4. After the processing is finished and the spectrum is displayed, select rows containing peaks 

with the right mouse button.  Usually, two or three rows are sufficient, if they contain peaks 
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near both ends of the spectrum.  The vertical scaling of the displayed 1D traces can be 

adjusted with the Scale:   buttons and the  buttons. 

5. Use the left mouse button to select a peak to be used as the pivot point.  

6. Click the   button.  Adjust the phase of 1D traces. When satisfied, click on the 

Apply and Exit button.  The 2D spectrum with the applied F2 phase correction will now be 

displayed. 

7. In the button panel, switch to column mode with  and do any required F1 phase 

correction. 

8. Use the Clear button in the Rows/Columns group to remove any displayed rows or columns 

and print any desired regions of the spectrum. 

8. Use the Edit 2D Processing Parameters… selection in the Edit menu to set F1 linear 

prediction to forward, the number of coefficients to 16 and the number of predicted points to 

256.  Exit the dialog by clicking the O.K. button.  In the 2D Processing and Display 

dialog, click the Both button to re-process the data.  You should see a significant 

improvement in the resolution in the F1 dimension. 

9. Print the spectrum, if desired. 
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Figure 19.   Edited phase sensitive HSQC spectrum of cyclosporine A recorded on an Avance III 

500.  Zhu-Bax LP has been applied in F1. 

3D Processing 

SpinWorks 4 includes 3D Processing for Bruker and Varian/Agilent data (JEOL still to come).  

The data are processed and displayed as a series of 2D planes, and most of the information on 2D 

processing is relevant to 3D processing. 

Definitions: 

1. F3 is the direct or acquisition dimension, and is also referred to as the X dimension.  

Currently, SpinWorks always displays this dimension along the horizontal axis. 

2. F2 is an indirect dimension, also referred to as the Y dimension.  For Bruker data, this is 

the dimension defined by the parameter set acqu2s and the delay d10.  For Varian/Agilent 

data this will be known as the “second indirect” dimension. 

3. F1 is an indirect dimension, also referred to as the Z dimension.  For Bruker data this is 



  

SPINWORKS 4.1 MANUAL 61 

 

the dimension defined by the parameter set acqu3s and the delay d0.  For Varian/Agilent 

data this will be known as the “first indirect” dimension. 

Selecting the Data 

Currently, SpinWorks cannot automatically discriminate 3D vs. 2D data, so it is necessary to set 

the data format to 3D before selecting the data.  Use the Data Format selection in the Options 

menu.  The data set can then be selected (ser or fid file).  The raw data (fids) from the first block 

will be displayed. 

Processing 3D Data 

3D data are processed as a series of 2D planes, followed by processing all of the individual 

columns of the third dimension.  You can process the XY planes followed by the Z dimension, or 

the XZ planes followed by the Y dimension.  Which order you do it in usually doesn’t matter, 

with the following exception:  If one of the indirect dimensions is “echo-antiecho” (sometimes 

called “Rance-Kay”), that dimension must be processed first.  You can also process the first 

plane of either the XY of XZ dimensions.  This is useful for determining phase angles and 

weighting parameters.  All of the 3D processing commands are available in the 3D sub-menu of 

the Processing menu. 

Displaying the Data 

The processed data are displayed as a series of 2D planes.  You can display either XY planes or 

XZ planes.  Display of YZ planes is not currently available.   You can step through the planes 

with the 3D- and 3D+ buttons on the toolbar.  The chemical shift of the currently displayed 

orthogonal dimension (e.g. Z if you are displaying XY planes) is shown on the status bar at the 

bottom of the screen. 

Steps in Processing a 3D Data Set 

It is assumed that you have some experience processing 1D and 2D data with SpinWorks. 

1. Switch SpinWorks to 3D mode and set the data type (Varian or Bruker). 

2. Select the 3D data set.  You must select the ser file (Bruker) or the fid file 

(Varian/Agilent) the entire series of fids is read into memory, so this may take a few 

seconds. 

3. Use either the button panel or the Edit menu to display the parameter editor.  Check that 

the size parameters are reasonable for a 3D data set.  Also check that the frequencies in 

the indirect dimensions are correct.  These should be specified in the processing 

parameters for the data set, but can be wrong if the data were not processed with the 

spectrometer vendor’s software.  Varian are especially bad in this regard, Bruker data sets 

seem to be much better.  

4. Varian/Agilent indirect dimensions that use States detection should have the reverse 

checkbox checked.  For Varian/Agilent indirect dimensions that use Echo-antiecho 

detection, leave the reverse check box unchecked, but make sure that the zero order 
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phasing is set to -90° in this dimension and that the Phasing mode is set to Constants. 

5. Process either the first XY or the first XZ plane (Processing Menu: 3D).  For data that 

are States or States-TPPI in both of the indirect dimensions, it really doesn’t matter which 

dimension you do first.  For data that are echo-antiecho (Rance-Kay), then you must 

select the plane containing the echo-anti-echo indirect dimension.  For example, for 

Bruker and Varian HNCO experiments, this would be the X-Y (F3-F2) dimension.   

6. After you have processed the first plane, phase the data as you would for any 2D data set.  

Normally, only X (F3) will require phasing.  Use the parameter editor to set the Phasing 

mode in X (F3) to Constants.  If you have made any phase adjustments to the indirect 

dimension, also set the Phasing mode in this dimension to Constants.  Note that Varian 

(only!) echo-antiecho data should already have the Phasing mode in this dimension set 

to Constants, and should already have a zero order phase of -90°.  For many NH 

detected experiments, what you should see at this point will look like a normal NH 

HSQC spectrum. 

7. You can process the first plane again if desired, just to be sure that the phasing is correct. 

8. Now process all the planes, either XY or XZ as appropriate (Processing Menu: 3D: 
Process XY Planes or Process XZ Planes).  This may take several minutes. 

9. After all of the planes have been processed, you can step through the individual planes 

with the 3D- and 3D+ buttons (Toolbar).  What you should see is a series of 2D spectra, 

where the amplitude of the cross-peaks varies with the plane number (evolution time in 

the third dimension).  The phase in the processed dimension (XY or XZ, as the case may 

be) should not generally change as a function of the evolution time in the unprocessed 

dimension. 

10. It is now necessary to process the third dimension.  This will be the Z dimension if you 

have processed the XY planes, and the Y dimension if you have processed the XZ planes.  

This is done through the 3D sub-menu of the Processing menu.  Processing the third 

dimension normally takes less a few minutes or less. 

11. You can now step through the individual planes using the blue 3D- and 3D+ buttons on 

the toolbar.  Since all three dimensions have been processed, you have the choice of 

either XY of XZ planes available in the View menu.  

12. During 3D processing, SpinWorks discards unneeded imaginary quadrants.  If necessary, 

in order to touch up the phase after transform, you must regenerate the imaginary 

quadrant using a Hilbert transform.  You can do a Hilbert transform of the direct or 

current indirect dimension of the current plane with the appropriate selection in the 3D 

Processing sub-menu.  
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Figure 20. NH plane of an HNCO experiment (AVIII 500) Processed with SpinWorks.  Zhu-Bax 

LP has been applies in the Y and Z dimensions. 

NMRPIPE Processed Data 

SpinWorks can read 1D, 2D and 3D processed data from the NMRPIPE program.  SpinWorks 

makes the following assumption about the data: 

1. The processing scripts for 2D and 3D use the –di option in the phasing command to 

discard the imaginary parts of the data.  For NMR Pipe 1D data you can eliminate the –di 

option, and the imaginary data will be available for phasing. 

2. File names for 1D data, the filename has to have the .ft extension, while for 2D data the 

filename has to have the .ft2 extension, and for 3D data the filename has to have the .ft3 

extension. 

3. File names for 3D files have the format *###.ft3, where * is any text, ### is the 3 digit 

plane number and the .ft3 suffix (extension) identifies it as 3D data.  For example 

test014.ft3 would be the 14th plane (in the Z direction) of the 3D data set.  The last line in 
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the processing script would therefore look something like: 

| pipe2xyz -out ft/test%03d.ft3 -z 

 

Note that most NMRPIPE scripts either use the above conventions or can easily be modified to 

do so. 

2D Data 

Use the Data Format sub-menu on the Options menu to set the data format to NMRPIPE.  Then 

select the 2D processed data (usually a file with the “.ft2” extension) with the Open command 

(File menu or toolbar).  The data can then be displayed and printed like any other 2D data.  In 

order to phase the data, you must Hilbert transform the data first (Processing menu) first. 

3D Data 

NMRPIPE stores 3D processed data as a series of 2D planes.  Each 2D plane is contains the X 

any Y dimensions, and the series of 2D planes is the Z dimension.  After setting the data format 

to NMRPIPE, each of these 2D planes can be read, displayed and printed as for any other 2D 

data.  There are two important differences with 3D data: 

1. NMRPIPE produces data files with extensions .ft1, .ft2 and ft3.  Only the .ft3 files 

(processed in all three dimensions) are valid 3D files for SpinWorks. 

2. If the file name contains a 3 digit plane number (e.g. test013.ft3) it is possible to step 

through the individual planes with the blue + and – buttons on the toolbar. 
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Figure 21. X-Y Plane of a 3D HNCO experiment processed with NMRPipe.   The Z dimension is 

the 15N Chemical shift. 

FID Math 

For some experiments it may be necessary to perform non-standard mathematical operations on 

an FID before transform.  The FID Math Toolbox (available from the Processing menu) can 

be used to accomplish this.  More operations can be added if requested. 

Notes: 

1. SpinWorks never (!) alters the original acquisition data.  Therefore, The FID Math 
Toolbox will not allow you to save FID files with the names “fid” or “ser”.  Names such 

as “fid1” or “ser3” are fine.   For 2D files that will be read in for further processing by 

SpinWorks, the output names “ser1” “ser2” or “ser3” are strongly recommended.  

SpinWorks will recognize these names and switch modes properly. 

2. Some of the operations in the toolbox operate on memory resident files, and others 

operate on files in the current experiment folder.  Operations on files require that the files 

be in the correct format.  The files must have the same byte order of Intel processors, and 
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must not have any prepended file or block headers.  The only native (raw spectrometer) 

files currently in the correct order would be FID files from Bruker spectrometers with 

X32 or PC computers.  However, operations exist to convert files to this format, and back 

into Varian format, if necessary. 

3. Because of differences in the way SpinWorks processes 1D vs. 2D data, some of these 

operations operate slightly differently on 1D or 2D data.   

For 2D data, after a file is selected (e.g. File Open) the acquisition data are read into 

memory and all processing uses this memory resident data as the input.  This means that 

if an FID Math operation produces undesirable results, you then have to re-select the data 

(File Open or recent files list) to restore the original acquisition data to memory. 

For 1D data, all processing uses the FID file on disk.  That means that any FID Math 

operation must save the file to disk and that you must select this file to process it. 

Operations available: 

Split Hypercomplex 2D Data into Separate Files 

This operation will split the current memory resident “fid” or “ser” data into two files 

representing the two quadrature “channels” in F1.  The default file names are “cos” and 

“sin” but other names can be entered, if desired. 

Phase Non-Hypercomplex 2D File (From Split) 

This operation fill apply a zero-order phase correction to each increment in a 2D file.  A 

time (t1) dependent phase correction can be applied by using a non-zero value for the 

increment (incr:).  The increment is the amount by which the phase is incremented for 

each t1 value.  Note that a time dependent zero order phase shift is equivalent to a 

frequency shift.  The file from the split (typically “sin” or “cos”) overwritten with the 

phase shifted data.  The original fid (raw data) file is not altered. 

Phase Current 1D or 2D FID and Save in File 

A zero order phase correction is applied to the current memory resident 1D or 2D FID 

data.  If the data is a hypercomplex 2D data set, the phase correction is applied to both the 

real and imaginary parts of t1.  A time (t1) dependent phase correction can be applied by 

using a non-zero value for the increment (incr:).  The phase corrected FID file is retained 

in memory (if 2D), and can be written to an output file (1D or 2D) if desired. 

Save Current FID in Correct Format 

Saves the current fid data to disk in the correct format for the FID Math functions.  The 

file fill have the byte order if the Intel processor and will have no file of block header 

information. 

Comb. FIDs in t1 

This function can be used to reassemble two split FID files into a hypercomplex file for 

processing.  The multiplier values can be used to scale the individual FIDs, but these 
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values will typically be 1 or -1. 

Add/Subt.  FIDs 

Produces a linear combination of two 1D or 2D FID files.  The files can be hypercomplex 

or split.  Setting the multipliers to 1 will add the files, will setting one of the multipliers to 

-1 will produce a difference file. 

Multiply FIDs 

Not yet implemented. 

 

 

Figure 22.  FID math dialog 

Trivial FID Math Example 

1. Select a 2D experiment that has been recorded with States or States-TPPI detection in F1. 

2. Use the Split Hypercomplex… function to split the 2D data sets into 2 separate files, 

called “cos” and “sin”.  These represent the real and imaginary parts in T1. 

3. In the Phase Non-Hypercomplex 2D file… box give “sin” as the file name and use a 

value of 180 for the ph0 value.  Click on the phase FID button. 

4. In the Bottom Row (under Comb. FIDs in t1) use “cos” and “sin” as the file names, 

leave the multipliers at 1.0, and  leave the output file name as “ser1”.  Click on the Comb. 
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FIDs in t1 button. 

5. Use File Open to select the “ser1” file.  Process the data.  Notice that the F1 direction is 

reversed?  This is one way of reversing the F1 direction of a 2D data set.  In SpinWorks, it 

is easier to select the reverse checkbox in the F1 panel of the Edit Processing 
Parameters dialog. 

6. Try the above with slightly different values for ph0.  Notice the appearance of F1 quad 

images now that the two quadrature channels in T1 are not orthogonal? 
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Simulation Tutorial 

SpinWorks uses the NUMARIT algorithm as described in: J. S. Martin and A. R. Quirt, J. Magn. 

Reson. 5, 318 (1971), and modified by Rudy Sebastian and others at the University of Manitoba 

(who re-named it NUMMRIT). However, none of the original FORTRAN code is used in 

SpinWorks.  SpinWorks uses a completely original implementation of the NUMARIT algorithm 

in C++. 

There are four dialogs available from the Spin System menu that can be used to specify 

simulation parameters. 

 In the Edit Chemical Shifts… dialog you define the nuclei or groups of nuclei that 

define the spin system.  You must specify:  

1. The number of nuclei in each group.  For example, a single nucleus would be entered 

as 1 and a methyl group would be 3.  A symmetric pair (AA´) would be entered as 

2*1. 

2. A symbolic label for each group.  Letter, numbers, underscores and dashes can be 

used. Terms like “Hpara” or “CH3” are fine. 

3. A species identifier. Identifying different groups as different species will cause them 

to be treated as “weakly coupled”.  Different nuclei should always be treated as 

different species, but you can identify different groups of the same nucleus as 

different species if the chemical shift between the groups is much larger than any 

coupling between them. 

4. The spin of the nucleus.  Spin ½ is default. 

5. The chemical shift in Hz. 

6. A check-box that defines whether a particular chemical shift should be optimized 

during an iterative calculation. 

 The Edit Scalar (J) Couplings... dialog is used to enter conventional J values in Hz. 

 The Edit Dipolar (D) Couplings… dialog is used to enter dipolar couplings in Hz.   Note 

that with dipolar couplings, couplings within an equivalent group are observed. 

 The Edit Simulation Options and DNMR Parameters… dialog is used to enter all of the 

simulation parameters that are not actually part of the Spin System.  The DNMR parameters 

are described in more detail in the DNMR section of this manual. 
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Figure 23.   Simulation options dialog with DNMR parameters 

A small library of sample spin systems is included with the program.  In a standard installation, 

these will be located in: C:\Program Files\SpinWorks_4\SpinSystems. 

ABX Spectrum 

1. Start SpinWorks, but do not select any experimental data. 

2. In the Spin System menu select Edit Chemical Shifts…  You will then be presented with a 

dialog for entering chemical shift and other information describing the spin system.  For 

Group 1, enter 1 for the number of spins, A for the label, proton for the species and 1000 for 

the chemical shift.  For Group 2, enter 1 for the number of spins, B for the label, proton for 

the species and 1010 for the chemical shift.  For group 3, enter 1 for the number of spins, X 

for the label, proton for the species and 3000 for the chemical shift. Leave the Spin values 

at ½. 

3. In the Spin System menu select Edit Scalar (J) Couplings…  Enter –12 for J(A,B), 2 for 

J(A,X) and 10 for J(B,X).   

4. In the Simulation menu select Run NUMMRIT Simulation.  In a few seconds, a simulated 

spectrum will appear on the screen.  Zoom in on the X multiplet at ca 6 ppm.  Use the cursors 

to measure the multiplet spacings.  Note that they do not relate all that well to the coupling 

constants!  This is a second-order or virtual coupling effect, and is much more common that 

one might think. 

5. Change the J(A,X) coupling to 0.  Use Run NUMMRIT Simulation in the Simulation 
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menu again.  Note that the X multiplet is still a doublet of doublets, although it is coupled to 

only one of the other protons.  Closer examination of the multiplet shows that there are small 

satellite peaks (more properly called combination lines) displaced about 16 Hz. from the 

centre of the multiplet.  These lines are an important clue that the spectrum is second order, 

but are easily lost in baseline noise. 

6. Set the B chemical shift to be identical to the A chemical shift (Edit Chemical Shifts…) and 

re-simulate the spectrum (Run Simulation).  The X multiplet looks like a triplet (with small 

combination lines) despite the fact that it is only coupled to 1 other proton. 

Analysis of the Orthodichlorobenzene Spectrum 

1. Locate the sample ODCB data This data set normally resides in C:\Program 

Files\SpinWorks_4\BrukerData. 

2. Read the ODCB data set (File: Open…).  This is the file odcb\2\fid located in the data 

directory as described in step 1. 

3. Process the spectrum with no window function. 

4. Read in a starting spin system with by loading the odcb_ni file (File: Read Spin System 
File…).   This file can be found in the same folder as the fid file. You can examine the 

starting parameters with the shift and scalar coupling editors if you desire (Spin System 

menu).  Particularly note how explicit two fold symmetry is described with the 2*1 entries in 

the spins field.  Also note that in a symmetric spin system like AABB, J(AB) will 

automatically be taken to be equal to J(AB) and that  J(A´B) will be taken to be equal to J(AB´). 

5. Select Edit Simulation Options and DNMR Parameters… in the Spin System menu.  

Set the Display Linewidth (Hz) setting to 0.05 (Yes, really). 

6. Run the simulation (Simulation: Run NUMMRIT Simulation).  A simulated spectrum 

somewhat like the experimental will be displayed above experimental spectrum.  The vertical 

offset and scaling of the calculated spectrum can be adjusted with the blue +, -, up-arrow 

and down-arrow buttons on the toolbar. 

7. The left and right keyboard arrow keys will move a transition cursor across the simulated 

spectrum.  Assign lines to these transitions by pointing to the corresponding experimental 

peak and clicking with the right mouse button.  The peak picking routine is used to find the 

peak closest to the cursor position.  If no peak is found within a reasonable distance of the 

cursor the transition is assigned to the raw cursor frequency.  When a transition is assigned, a 

red line will be drawn between the transition and its corresponding peak.  Continue assigning 

all of the lines in the spectrum.  A wrongly assigned transition can be deleted with the 

keyboard “d” key. 

8. In the Spin System menu, use the Edit Chemical Shifts… and Edit Scalar (J) 
Couplings… dialogs to check the iterate boxes for both chemical shifts and all four 

couplings.  In the Spin System menu select Edit Simulation Options and DNMR 
Parameters…  Check the Optimize, Autoignore and Autoassign boxes.  
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9. Run the simulation (Simulation: Run NUMMRIT Simulation).  The new spectrum that will 

be displayed should be a very close match to the experimental.  If not, check the simulation 

output (Simulation: List Simulation Output) for possible clues as to what might be wrong. 

10. It the simulation was satisfactory, load the new parameters (Simulation: Load Optimized 
Parameters) into the spin system editor, and re-run the simulation.  Examine the simulation 

output (Simulation: List Simulation Output).  The RMS deviation between the 

experimental and calculated spectra should be less than 0.01 Hz at this point. 

11. Load these final optimized parameters (Spin System: Load Optimized Parameters) and 

save the new spin system to disk (File: Save Spin System As…) and likewise save the 

assigned transitions (File: Save Assigned Transitions As…) for future use. 

Analysis of the Fluorobenzene Spectrum 

1. The fluorobenzene spectrum supplied with SpinWorks is in XwinNMR format.  Using File: 
Open…, select the fid file of experiment number 1, and process with FT.  Phase the 

spectrum.  This spectrum was recorded on an Avance 300 using gradients and a selective 

pulse to reduce the effective sample length and thus improve resolution (pulse sequence 

available on request).  Slight baseline distortions are observed due to the lock hold circuitry 

releasing immediately before acquisition and diffusion within the sample.  This has 

absolutely no effect on spectra recorded at "normal" resolution.  Note that the spectrum 

shown below is an older one of the same sample recorded on an AM300.  Note that this 

sample data set will have to be moved to a path with no embedded blanks, just as described 

for the orthodichlorobenzene sample above. 

2. Read in the spin system file pfb.ss (File: Read Spin System File…).  This file will 

normally reside in the same folder as the raw data (fid) for the fluorobenzene data.  Set the 

simulation display linewidth to 0.06 Hz (Simulation: Edit Simulation Parameters…).  

Yes, we really can shim our 300 that well . 

3. Run a non-optimized simulation. 

4. Assign as many transitions as possible.  Note that this is a more difficult analysis and that not 

all of the transitions can be assigned at this point. 

5. Check that all proton shifts and all couplings are selected for optimization (Spin System 

menu), and Set the simulation to run with optimization, autoassign and autodelete (Spin 
System menu). 

6. Run the simulation.  The fit at this point should be fair, but not great.  If it looks like a 

reasonable improvement then load the optimized parameters (Simulation menu), assign 

more of the transitions, and re-assign any that were obvious mistakes.  If the fit did not 

improve, it is probable that you did not assign enough lines or misassigned too many. Repeat 

steps 3 and 4. 

7. Run the simulation.  The fit should be quite good at this point.  Continue assigning lines and 

loading optimized parameters until the fit no longer improves.  The RMS at this point will 



  

SPINWORKS 4.1 MANUAL 73 

 

typically be 0.006 Hz or better. 

8. Print the spectra. 

 

 

Figure 24.   Analysis of the fluorobenzene spectrum: high field portion.  This is the final fit after 

two rounds of iteration.  The RMS deviation between experimental and calculated peak positions 

is 0.004 Hz.  The Simulated spectrum has a calculated linewidth of 0.06 Hz. 

 

Spinworks NMR: C:\users\marat\programs\SpinWorks\fluorobenzene\1\fid    NUMARIT analysis of fluorobenzene in acet d6

PPM   7.18     7.16     7.14     7.12     7.10     7.08     7.06   

file: C:\users\marat\programs\SpinWorks\fluorobenzene\1\fid   expt: <>
transmitter freq.: 300.130000 MHz
time domain size: 8192 points
width:   189.83 Hz = 0.632477 ppm = 0.023172 Hz/pt
number of scans: 16

freq. of 0 ppm: 300.134930 MHz
processed size: 16384 real points
LB:   -0.070    GB: 0.6000
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Figure 25.   Low field portion of the fluorobenzene analysis 

Spinworks NMR: C:\users\marat\programs\SpinWorks\fluorobenzene\1\fid    NUMARIT analysis of fluorobenzene in acet d6

PPM   7.42     7.40     7.38     7.36     7.34   

file: C:\users\marat\programs\SpinWorks\fluorobenzene\1\fid   expt: <>
transmitter freq.: 300.130000 MHz
time domain size: 8192 points
width:   189.83 Hz = 0.632477 ppm = 0.023172 Hz/pt
number of scans: 16

freq. of 0 ppm: 300.134930 MHz
processed size: 16384 real points
LB:   -0.070    GB: 0.6000
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HOGWASH Resolution Enhancement 

This is an implementation of Ray Freeman's HOGWASH (Second-Hand Experiment for the 

Elucidation of Partially resolved Data using an Iterative Procedure) algorithm incorporated into 

the Xsim/SpinWorks simulation package.  The original papers (J. Magn. Reson. 76, 476 (1988); 

56, 463 (1984); 56, 294 (1984)) should be consulted for details of how the technique works.   

The current implementation will process data with a real data size of up to 512k points (2 

Mbytes). This is not an array size limit but is included to force a degree of reasonableness.  

General Comments 

Be reasonable.  Resolution enhancement (especially non-linear processing) is not the solution to 

all resolution problems.  Enhancement factors of up to ca 5 are possible with careful application 

of the program to good data.  Users are strongly encouraged to read the homily on page 492 of 

the paper by Davies et al. (J. Magn. Reson.  76, 476 (1988)). 

The choice of a synthetic vs. an observed mask (reference) peak depends on the nature of the 

resolution problem.  In cases where the peaks can reasonably be assumed to be Lorentzian (i.e., 

relaxation is the problem) then a synthetic Lorentzian mask is appropriate, although the synthetic 

mask peak may be either Lorentzian or Gaussian.   If field inhomogeneity is limiting the 

resolution, an observed mask (reference) peak is essential.  This must be a sharp single line of 

reasonable intensity in a clear region of the spectrum.  Note that TMS and other silylated 

reference compounds are usually poor choices because of the 29Si satellite peaks.  Both the 

spectral region being enhanced and the mask peak must be well phased and baseline corrected if 

necessary.  The compound chosen for the mask peak should be reasonably well T2 matched to 

the peaks to be enhanced, especially if a component of natural line width is to be removed from 

the spectrum.  If the mask peak has a considerably greater T2 than the compound under 

investigation, then only a small component of natural line width will be removed from the 

spectrum.  Any instrumental contribution will still be removed, however.  If the mask peak has a 

considerably shorter T2 than the compound under investigation, severe baseline distortion will 

result.  The frequency domain data (spectrum) must be very well digitized.  This may involve 

zero-filling the FID to 4 or even 8 times the original time domain size.  The spectrum should also 

have a reasonable signal to noise ratio and spectra with extremely high dynamic range should be 

avoided.  

Using the Technique 

The spectrum to be enhanced should be processed normally using SpinWorks.  Pay particular 

attention to phasing and baseline.  If the acquisition time is considerably longer than the effective 

T2, some EM is appropriate to optimize the signal to noise ratio without excessively broadening 

the peaks. If an observed mask peak is being used, record its frequency or shift.   

Before using the enhancement package, there are a number of parameters that must be set.  These 

can be set in the Edit HOGWASH Parameters...dialog of the Edit menu: 
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Mask Peak Information 

When using a synthetic mask peak some degree of trial and error is required.  It is best to start 

with a fairly narrow mask and increase it until the desired degree of enhancement is obtained. 

Severe baseline distortion will result from the use of a too-wide mask peak.  For an observed 

mask peak, enter the position of the peak and the range over which the mask should be defined. 

This range should be at least 10 times the line width of the mask peak but is limited to 4000 

points.  The larger the range, the more slowly the program will execute.  

You can define the position of the mask peak by defining it with a single cursor before starting 

the HOGWASH parameter dialog. 

Loop Gain and Threshold  

Typical values for the loop-gain () are less than 0.03, with 0.01 usually giving good results.  

Smaller values are better but slower.  The termination threshold is defined as a fraction of the 

tallest peak in the region being enhanced.  The threshold value depends on the dynamic range of 

the spectrum, and should be above the noise level - otherwise the program will attempt to 

synthesize the baseline noise.  A threshold value just above the noise level is usually appropriate. 

The default value of 0.01 works well in most cases provided that the signal to noise ratio is good. 

The Reconstruction Line Width 

This is another variable that often requires some experimentation.  It must be several times the 

digital resolution, however.  A value 3 to 5 times narrower than the mask peak half-height width 

seems to give good results.  Too high a value will result is insufficient enhancement.  Too low a 

value may introduce false structure into the spectrum. 

Starting the Calculation 

The enhancement is started from the Processing menu. The enhancement is only applied to the 

displayed region of the spectrum.  If other regions of the spectrum are to be enhanced, then they 

can be done serially, avoiding the need to apply the enhancement to baseline or uninteresting 

portions of the spectrum.  If the procedure, for whatever reason, messes-up the spectrum, it will 

be necessary to re-process the FID. (e.g. with the Process button or with the Processing 

menu). 

Saving Enhanced Spectra 

Enhanced processed spectra can be saved in JCAMP-DX or SpinWorks native format with the 

appropriate commands in the File menu. Enhanced spectra are also saved in SpinWorks format if 

the auto save feature is turned on (Set Preferences… selection in the Options menu) 

Speed 

Typical calculation times are from a few seconds to a few minutes, depending on the problem 

and the computer used.  The figure below shows HOGWASH processing of a fluorosugar 
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spectrum with: loop gain = 0.02, threshold = 0.01, reconstruction linewidth = 0.2 Hz., mask = N-

Acetyl peak (1036.5 Hz), mask width = 20 Hz, zero-filling to 128 k., Top: HOGWASH 

enhancement, middle: GM enhancement, bottom: normal processing (LB = 0.2).  This 

calculation requires only a few seconds on a recent computer. 

 

 

 

Figure 26.  HOGWASH processing of a fluorosugar spectrum.  See text for details. 

Application of HOGWASH Processing to the Indirect Dimension (F1) of 2D 

Spectra 

Multidimensional spectra often suffer truncation artifacts  (“sinc wiggles”) resulting from short 

acquisition times in the indirect dimensions.  The obvious solution of lengthening these 

acquisition times often results in an unacceptable increase in experiment time, and can decrease 

the signal to noise ratio.  Apodization, of course, can reduce or eliminate the artifacts at the 

expense of resolution.  Most NMR processing software includes linear prediction routines to 

extend the time domain data.  Linear prediction uses a set of coefficients derived from singular 

value decomposition (SVD) or maximum entropy methods3 (the so-called Burg algorithm) to 

                                                 
3 Not to be confused with maximum entropy reconstruction. 

Spinworks NMR: F:\pgh-VI.76\2\fid    Phil's fluorosugar in D2O, AMX500, 1-H

Hz  2200.0   2160.0   2120.0   2080.0   2040.0   2000.0   1960.0   1920.0   1880.0   1840.0 

file: F:\pgh-VI.76\2\fid   expt: <zg>
transmitter freq.: 500.139572 MHz
time domain size: 32768 points
width:  7042.21 Hz = 14.080577 ppm = 0.214911 Hz/pt
number of scans: 16

freq. of 0 ppm: 500.136716 MHz
processed size: 131072 real points
LB:    0.200    GB: 0.3500
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extend the data in the truncated dimensions.  However, “there is no such thing as a free lunch”, 

and linear prediction can create a number of well documented but not often appreciated problems 

and artifacts.4 The Burg algorithm, in particular, is prone to problems such as line splitting 

(introducing false multiplet structure) and frequency shifting. 

HOGWASH is modeled on a procedure used to solve an exactly analogous in radio astronomy.  

The finite aperture of the radio telescope relative to the wavelength creates artifacts similar to the 

truncation artifacts seen in multi-dimensional NMR.  In both cases, the instrument lineshape 

function can be calculated or measured, and can readily be deconvoluted out of the spectrum in a 

step-wise procedure.   For two-dimensional NMR, the instrument lineshape function can easily 

be calculated as the Fourier transform of a step function running from 0...t1, as field 

inhomogeneity usually has little effect for short values of t1.  Any additional apodization can be 

applied to this function, if desired.  This application of HOGWASH to the removal of truncation 

artifacts was first proposed by Keeler (J. Magn. Reson. 56, 463 (1984)) but, until now, the 

method has not been incorporated into readily available software packages.  Note that other 

lineshape problems, such as “phase twist”, can be treated with the same method (Shaka et al. J. 

Magn. Reson., 56, 294, (1984)). 

2D HOGWASH Parameter Selection 

The optimum parameters for applying HOGWASH to 2D truncation problems are somewhat 

different than when using the procedure for general 1D resolution enhancement.  The loop gain 

and termination threshold can be considerably higher.  The peak width used for reconstruction 

must be larger, on the order of the digital resolution in F1.  The default parameters are 

appropriate for many situations.  These parameters enable the 2D version of HOGWASH to run 

considerably faster than the 1D version.  For 2D, the default reconstruction lineshape is 

Gaussian.  This is primarily a cosmetic choice, as it seems to give nicer 2D contour plots than 

Lorentzian. 

Using the Technique 

1. Process the 2D spectrum with normal window functions and the phasing mode set to none. 

(Edit menu, Edit 2D Processing Parameters…)  Use considerable zero filling in F1.  If the 

number of time domain points in F1 was 256, zero filling to 1K would be reasonable. 

2. Phase the spectrum carefully. 

3. In the Edit 2D Processing Parameters… dialog, set the phasing mode in both dimensions 

to constants, and set the F1 window function to none.  In the F1 HOGWASH Parameters, 

group set the Mask Width parameter to one half of the F1 size parameter.  The 

Reconstruction linewidth should be set to approximately the digital resolution (Hz/point) in 

the F1 dimension.  This may be 10 Hz to 20 Hz for an experiment like HSQC, but may be 1 

Hz to 5 Hz for a homonuclear correlation experiment such as COSY. 

4. Process the spectrum in both dimensions.  You should see a phased 2D spectrum with 

                                                 
4 See, for example, A. S. Stern, K. Li, and J. C. Hoch, J. Amer. Chem. Soc. 124, 1982 (2002). 
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truncation artifacts in F1.  Select the region to apply the HOGWASH processing.  This can be 

the entire spectrum, if desired.  Note that HOGWASH is applied to the entire F1 width, but 

only to the F2 region displayed on the screen. 

5. In the 2D Processing sub-menu of the Processing menu, select HOGWASH F1.  The 

processing can be applied serially to other regions of the spectrum, if desired. 

6. If selection of HOGWASH parameters was not appropriate, it will be necessary to re-process 

the data (use the Both button in the 2D Processing and Display dialog). 
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Figure 27.  HOGWASH processed HSQC spectrum of strychnine 

1. (Top) Processing with no window function in F1.  Severe truncation artifacts are 

observed in F1. 

2. (Middle) Processing with 8 coefficient SVD linear prediction to 128 points in F1. 

3. (Bottom) HOGWASH Processing. The parameters were: loop gain = 0.10, termination 

threshold = 0.05, mask width = 512 points, reconstruction linewidth 15 Hz (Gaussian).  

This calculation required approximately three seconds on a 1.7 GHz Pentium 4 under 

Windows 2000. 
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file: C:\data\marat\nmr\strych_hwtest\2\ser   expt: <invietgpsi>

transmitter freq.: 300.131407 MHz

time domain size: 2048  by  64 points

width:  2394.64 Hz = 7.978625 ppm = 1.169256 Hz/pt

number of scans: 8

F2: freq. of 0 ppm: 300.130006 MHz

processed size: 4096 complex points

window function: Sine Squared

shift:  90.0 degrees

F1: freq. of 0 ppm: 75.467749 MHz

processed size: 2048 complex points

window function: NONE

shift:  90.0 degrees
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Figure 28.   HOGWASH processing (expanded plot) showing resolution in F1 of approximately 

15 Hz.  Only 64 increments were recorded in F1 over a total width of 12,000 Hz, for a raw 

digital resolution of about 190 Hz. 
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Figure 29.   F1 columns extracted from an HSQC spectrum   

Top: no window function  

Middle: Linear prediction followed by sine squared apodization 

Bottom: HOGWASH processing   

Note that linear prediction has minimal effect on the resolution, but allows a less severe 

apodization by extending the effective acquisition time.  The “sinc wiggles” that remain in the 

outer edges of the HOGWASH spectrum result from using a mask width that was too narrow 

(512 points). 

SpinWorks 2.0:   Strychnine, short T1 for HW test column at 4.297557 ppm

PPM   140.0    130.0    120.0    110.0    100.0    90.0     80.0     70.0     60.0     50.0     40.0     30.0     20.0     10.0    0.0   

file: C:\data\marat\nmr\strych_hwtest\2\column2237.dx   expt: <invietgpsi>

transmitter freq.: 75.473348 MHz

time domain size: 64 points

width: 12561.88 Hz = 166.441299 ppm = 196.279408 Hz/pt

number of scans: 8

freq. of 0 ppm: 75.467749 MHz

processed size: 2048 complex points

LB:    0.000    GB: 0.0000
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Dynamic NMR Simulation 

SpinWorks can interface to two external programs for the simulation of exchanged broadened 

NMR spectra.  The first is the venerable old DNMR3 program of D. Stephenson, G. Binsch and 

D. Kleier, while the second is the much newer MEXICO of Alex Bain.  The following 

summarizes the features and drawbacks of the two programs: 

DNMR3 

 Handles fairly large spin systems, including groups of equivalent spins (e.g. methyl groups.)  

It can also use symmetry (e.g. AA) factoring, but the SpinWorks user interface does not 

include this. I doubt that symmetry factoring would be that useful for most dynamic NMR 

problems – anyone care to prove me wrong? The limit is 5 individual spins, or more if you 

have equivalence. 

 The program can handle both mutual (e.g. ABBA) exchange and non-mutual (e.g. 

ABCD) type exchanges. 

 Up to three chemical configurations can be included. For example, ABCDEF. 

 The program can occasionally suffer from numerical instability. 

 Reference: D. S. Stephenson and G. Binsch, J. Magn. Reson. 30, 625 (1978). 

MEXICO 

 Handles very large spin systems, but does not include symmetry or equivalence factoring.  It 

can include weak coupling (X approximation) though.  Since memory in this program is 

dynamically allocated, the maximum size of the spin system is unknown.  With the 

SpinWorks interface, the practical limit is 5 individual spins.  Bigger systems can be handled 

by manually editing the mechanism file. 

 The program can handle both mutual and non-mutual exchange. 

 The program is currently limited to two chemical configurations. 

 The program is much faster and considerably more stable than DNMR3. 

 The treatment of relaxation is more accurate than that in DNMR3. 

 The complete MEXICO manual is available from Alex Bain at: 

http://www.chemistry.mcmaster.ca/faculty/bain 

 References:  

1. A. D. Bain and G. J. Duns, Can. J. Chem. 74, 819, (1996). 

2. A. D. Bain, D. M. Rex and R. N. Smith, Magn. Reson. Chem. 39, 122 (2001). 

 

General Notes on DNMR3 and MEXICO 

The DNMR parameters for SpinWorks 3 are now in the Simulation Options and DNMR 

http://www.chemistry.mcmaster.ca/faculty/bain
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Parameters… dialog of the Spin System menu. 

These programs run as external modules (.exe files) to SpinWorks.  SpinWorks expects to find 

these modules (dnmr3.exe and mexico.exe) in C:\Program Files (X86)\SpinWorks_4, the 

default SpinWorks installation folder.  If you installed SpinWorks in a different location (or if a 

32 bit version of Windows installed it in a different location, e.g. C:\Program 
Files\SpinWorks_4), then you must configure this in the Set Preferences... selection in the 

Options menu.  Information is passed back and forth between these modules and SpinWorks via 

files, which are normally generated in C:\Temp.  For MEXICO, this scratch folder can be 

changed in the Set Preferences... selection in the Options menu. DNMR3, however currently 

requires the presence of the C:\Temp folder to operate.  All current Windows versions should 

have this folder. If you don’t, then simply create it. The following files are generated: 

 Dnmr.mch   This is the input file for dnmr3, and is generated by the SpinWorks spin 

system editors. 

 Mexico.mch   This is the input (mechanism) file for MEXICO, and is generated by the 

SpinWorks spin system editors. 

 Dnmr.out.   This is the output spectrum from DNMR3, and is read by SpinWorks to 

create the displayed simulated spectrum.  This is an ASCII file and X,Y 

frequency-intensity pairs. 

 1r    This is the digital spectrum produced by MEXICO.  It has exactly the 

same format as the file of the same name in Bruker’s XwinNMR.  The 

byte order is that of the INTEL processor so, if you import this file into an 

XwinNMR or TopSpin data, set the appropriate parameter in the procs file 

must be correct.  SpinWorks reads this file in order to display the 

simulated spectrum. 

Note that the versions of DNMR3 and MEXICO supplied with SpinWorks have been modified 

from the originals in order to work with SpinWorks.  The original MEXICO (for SGI IRIX, and 

designed to work in conjunction with Bruker’s XwinNMR, or, I hate to admit, mNova is 

available from Alex Bain at: bain@mcmaster.ca. The original DNMR3 program is available 

from numerous places on the web. 

Note that all valid DNMR/MEXICO parameter sets are also valid for NUMMRIT calculations, 

and that any NUMMRIT parameter set that would be suitable can be turned into a 

DNMR/MEXICO parameter set by adding the appropriate DNMR parameters (Spin System 

menu). 

If you are doing DNMR3 or MEXICO calculations with experimental data present, then the 

entire path to the experimental data can contain no blanks.  This is a result of the UNIX style 

programming practices used in DNMR3 and MEXICO.  Therefore, do not place your data in a 

folder like “C:\my nmr data”, but instead use something like “C:\my_nmr_data” instead.  Putting 

NMR data in the “My documents” folder creates similar problems. 

The Edit Simulation Options and DNMR Parameters… (Spin System menu) dialog is used 

mailto:bain@mcmaster.ca
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to specify many of the dynamic NMR parameters. 

 

Figure 30.   Simulation options menu  

Despite what some people might tell you, Windows is a true multi-threaded multi-tasking 

operating system.  In SpinWorks, simulations are run as a separate “thread”, and the program 

polls the simulation thread to see if it has finished.  If a simulation hasn’t finished after a certain 

number of seconds, a timeout will occur.  The default for this time period is 10 seconds, but can 

be by changing the Simulation Timeout (sec) value in the Simulation Options dialog. 

Simulations can be started from the Simulation menu or with a pop-up dialog that can be started 

with the yellow Simulate button on the button panel.  The following is a summary of the 

simulation dialog functions: 

NUMMRIT Starts a NUMMRIT simulation using the existing spin system definition.  Since 

all DNMR3 and Mexico spin systems are also valid NUMMRIT spin systems, 

this button will also work in DNMR3/MEXICO mode 

DNMR3 Starts a DNMR3 simulation.  SpinWorks must be in DNMR/MEXICO mode and 

a valid DNMR3 spin system must exist. 

MEXICO Starts a MEXICO simulation.  SpinWorks must be in DNMR/MEXICO mode and 

a valid MEXICO spin system must exist. 

K(1,2)       Sets the rate constant for a two site DNMR3 or MEXICO simulation.  For 

systems with more than 2 sites use the Edit Simulation Options and DNMR 
Parameters… dialog in the Spin System menu. 
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Assign       This button is used to autoassign peaks in the displayed region of the spectrum.  

This would be used in an iterative NUMMRIT analysis.  The fit must be 

reasonably good for this feature to work, so a few rounds of manual assignment 

and iteration may be required first. 

Delete       Deletes assignments in the displayed region. 

RMS Displays the relative RMS deviation and χ2 fit between the simulated an 

experimental spectrum over the displayed region.  Primarily used for DNMR3 and 

MEXICO calculations. 

 

Figure 31.   Simulation panel 

Treatment of Relaxation 

DNMR3 treats relaxation in a very rudimentary fashion.  An effective T2 determines the 

linewidth of each spectral line in the absence of chemical exchange or at the extreme fast 

exchange limit.  MEXICO’s treatment of relaxation is far more sophisticated.  A separate T1 

value can be entered for each nucleus.  T2 is considered to be equal to T1.  T1, however, also 

affects the linewidth of any coupled nuclei, and this is properly handled in MEXICO.  An 

example of this is the self decoupling of 14N from 1H.  With SpinWork’s DNMR/MEXICO 

interface, a single T1 is entered, and is considered to be equal for all nuclei.  This should be 

adequate for most applications.  If you find it necessary to enter separate T1s, it is a simple matter 

to manually edit the MEXICO mechanism file. (Spin System menu). 

Example Files 

A number of sample spin system files suitable for DNMR calculations are included in the 

DNMR folder of the standard installation (C:\Program Files\SpinWorks_4\DNMR).  These have 
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the additional necessary DNMR parameters. These example files currently include: 

 dnmr_test3.ss  AB to BA mutual exchange. This file is suitable for both DNMR3 and 

MEXICO. 

 dnmr_test4.ss     AB to CD non-mutual exchange.  This file is suitable for both DNMR3 

and MEXICO. 

 dnmr_test5.ss     A2B2 to B2A2 mutual exchange.  This file is suitable for DNMR3 but 

cannot be used for MEXICO because there is more than one spin in a 

group.  MEXICO could probably handle this system as ABCD to CDAB 

with A = B and C = D; J(A,B) = J(C,D) = 0, and J(A,C) = J(B,C) = 

J(A,D) = J(B,D).  The permutation vector for the exchange would be 

3412.  Give this a try, if you like. 

 dnmr_test6.ss   AB to CD to EF three site non mutual exchange.  This file is suitable for 

DNMR3 only as MEXICO is currently restricted to two sites. 

 dnmr_test7.ss     ABC to BAC mutual exchange.  Suitable for both DNMR3 and MEXICO. 

 dnmr_test8.ss    ABC to BAC to CAB three site mutual exchange.  DNMR3 only. 

Parameters Required for DNMR Simulation 

The spin system is described in the same manner as it would be for a high resolution 

(NUMMRIT) simulation.  There are, however, a couple of differences, primarily affecting the 

chemical shift editor.  For MEXICO, the number of spins in each group is limited to one.  For 

DNMR3, this can be 1, 2, or 3.  The species identifier is treated quite differently.  Rather than 

specifying a different nuclear species (e.g. 13C vs. 1H), the species identifier specifies a different 

chemical species for cases of non-mutual exchange (e.g. ABCD).  For mutual exchange all 

nuclei must be the same species (MEXICO can handle weak coupling, but it must be entered 

differently).  For the ABCD case, the first two nuclei would be entered as species 1, while the 

second two would be entered as species 2.  The actual symbols used to describe the species don’t 

matter, as long as they are different.  Once correctly described in the chemical shift editor, the 

coupling constant editor will recognize all valid coupling constants.  For instance, for the 

ABCD case, the coupling constant editor will have entries for J(A,B) and J(C,D), but not for 

J(A,C) etc.  In effect, you are entering two separate spin systems.  In addition to these differences 

in defining the spin system, there are a number of DNMR specific parameters that must be 

entered into the Edit Simulation Options... dialog of the Spin System menu. 

T2 (for DNMR3) or T1 (for MEXICO)   

For DNMR3, this parameter defines the linewidth in the absence of exchange. T2 = 

1/(1/2).  For MEXICO, this is the actual (or more likely estimated) T1 value of the 

nuclei.  T2 is assumed to be equal to T1 and both effect the linewidth in the absence of 

chemical exchange.  The current parameter editor sets the T1 of all nuclei to be equal, but 

you can override this with a manual edit of MEXICO’s mechanism file.  Future versions 
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will allow you to enter separate T1 values for each nucleus. 

Mutual Exchange (checkbox)   

This parameter defines whether the exchange is mutual, or not. 

Rate Constants   

For mutual exchange only a single rate (K(1,2)) can be defined.  For non-mutual 

exchange, the forward rate for the exchange between site should be entered. 

Number of Species   

Can be set to either 2 or 3.  The current MEXICO release can only handle 2 species cases. 

Permutation Vectors   

This string of integers defines the identity of the nuclei after exchange.  The first 

permutation vector is taken to be the unity permutation 1,2,...,n where n is the number of 

nuclei.  DNMR requires these vectors only for mutual exchange, one vector for two site 

exchange and two vectors for three site exchange.  For an ABBA mutual exchange, the 

permutation vector would be 2,1.   MEXICO requires a permutation vector for non-

mutual exchange as well, but can usually be set to the unity permutation.  Please see the 

MEXICO manual for complete details.  Note that SpinWorks and DNMR3 numbers the 

nuclei starting with 1, and the permutation vectors are internally converted into 

MEXICO’s 0 based (C type) counting . 

Populations   

These are the populations of the sites for cases on non-mutual exchange. 

DNMR Tutorial 

ABBA Mutual Exchange 

1. Start up SpinWorks with no experimental data.  Use the Options menu to set the simulation 

mode to DNMR3/MEXICO. 

2. Under the Spin System menu choose Edit Chemical Shifts...  Enter two nuclei as follows: 

 

3. Also under the Spin System menu, choose Edit Scalar (J) Couplings...  Set J(A,B) to 12 
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Hz.  Remember only to change the numeric part of the coupling constant field. 

4. Use the Edit Simulation Options and DNMR Parameters... dialog in the Spin System 

menu to set the following DNMR parameters:  K(1,2) = 5; Permutation Vector (2) = 2 1 
and T2 = 1 (the default).  Make sure that the mutual box is checked, and that the number of 

chemical configurations (sites) is set to 2.  Since this is mutual exchange, the population 

values do not need to be set. 

5. Use the Run DNMR simulation command in the Simulation menu to run the simulation.  A 

black command interpreter window will appear briefly, and a simulated spectrum should 

appear.  You can also run DNMR from the Simulation pop-up panel that can be started form 

the Yellow Simulate button on the button panel. 

6. Run the same calculation with MEXICO by using the Run MEXICO simulation command 

(Simulation menu).  If you see a spectrum here and in step 5, then both DNMR3 and 

MEXICO are installed properly and are working.  Use List Simulation Output command 

(Simulation menu) to view the text output (e.g. for possible errors) from either of these 

programs. 

7. The default spectral width (5000 Hz) is a bit big for this simulation, so let’s reduce it.  Use 

the Edit Simulation Options and DNMR Parameters... dialog in the Spin System menu 

to reduce the Display Width to 1000 Hz and the Offset to 1000 Hz.  Recalculate the 

spectrum with either DNMR3 or MEXICO. 

8. Experiment with the effect of changing the rate constant on the spectrum.  You can save any 

of your calculations to a stacked trace with the Copy Simulated to Stack command in the 

View menu. 

9. Print the spectrum, if desired. 

ABC  BAC Mutual Exchange 

1. Using the spin system editors, Set up an ABC spin system with A = 500 H, B = 550 Hz 

and C = 800 Hz.  Set J(A,B) = 12 Hz, J(A,C) = 10 Hz and J(B,C) = 2 Hz.  Using the DNMR 

parameter editor (Spin System menu) set Permutation Vector 2 to 2 1 3 and the rate 

constant to 5 s-1.  Chemical Configurations (2 or 3) should be set to 2.  This is one of the 

standard DNMR spin systems distributed with SpinWorks, so it can also be set up by reading 

in the spin system from disk. Use the Read Spin System… selection in the File menu.  The 

file is dnmr_test7.ss and should be located in C:\Program Files\SpinWorks\dnmr. 

2. Run the simulation with both MEXICO and DNMR3.  Experiment with different values of 

the rate constant.  The spectra should look something like the following: 
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3. Notice that the two outer lines of the C multiplet remain sharp.  Using simple  type spin 

basis functions, explain why this is so. (CHEM 4600 students take note ) 

4. Switch the simulation mode to NUMMRIT (Options menu).  Re-run the simulation with 

Run NUMMRIT Simulation (Simulation menu).  Notice how easy it is to switch back and 

forth between the two calculation modes.  For a strongly second order exchanging system, a 

good technique is to analyze the slow exchange spectrum with NUMMRIT first to obtain 

accurate spectral parameters.  It is then an easy matter to switch to DNMR or MEXICO to 

simulate the exchanging spectra. 

ABC: Effect of T1 Relaxation (MEXICO) 

While not exactly Dynamic NMR, the following is an interesting demonstration. 

1. Set up the ABC spin system exactly as in the previous example (dnmr_test7.ss).  Set the rate 

constant to 0, but the other dnmr parameters should be the same. 

2. Simulate the spectrum using MEXICO.  A nice, non-exchange broadened spectrum should be 

displayed. 

3. Select the View or Edit MEXICO Mechanism File command in the Spin System menu.  

Find the relaxation rates line for the first site, and set the relaxation rate (not the exchange 

PPM   1.60   1.50   1.40   1.30   1.20   1.10   1.00   0.90

file: (null)   expt:
transmitter freq.: 500.000000 MHz
time domain size: 0 points
width:  1000.00 Hz = 2.000000 ppm
number of scans: 0

freq. of 0 ppm: 499.999500 MHz
processed size: 16384 real points
LB:    0.000    GB: 0.0000

SpinWorks/MEXICO Dynamic NMR simulation:  ABC to BAC

ABC

10 s-1

100 s-1

1000 s-1

20000 s-1
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rate) for nucleus “C” (the third number on the line) to 10000.0.  You do not need to change 

the rate of the second site as this is mutual exchange.  (Read Alex’s MEXICO manual, if you 

need help understanding the format of the mechanism file). 

4. Re-simulate the spectrum with MEXICO.  What do you see?  Why? 

AB to CD Non Mutual Exchange 

This is a simulation of two different spin systems in equilibrium. 

1. Read in the spin system file dnmr_test4.ss (it should be in C:\Program 

Files\SpinWorks\dnmr). 

2. Using the spin system editors (in the Spin System menu) examine how the shifts and 

couplings are entered for a system of this type.  Especially note how the species designator is 

used for the chemical configuration (site) and how the coupling editor only shows couplings 

within a chemical species. 

3. Use the DNMR parameter editor to examine the dnmr parameters. 

4. Simulate the spectrum with DNMR3 and MEXICO.  Experiment with different values of the 

rate constant and populations. 
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Reading SIMPSON Data 

SIMPSON is a very powerful program for the simulation of many types of solid-state NMR 

experiments.  SIMPSON can generate both time domain data (FIDs) and frequency domain data 

(spectra).  For a complete description of SIMPSON please see: M. Bak, J. T. Rasmussen and N. 

C. Nielsen, J. Magn. Reson. 147, 296-330 (2000).  The program, examples, and a PDF version of 

the J. Magn. Reson. Paper can be downloaded from:   http://nmr.imsb.au.dk 

SIMPSON is available for Windows, Linux and several flavours of UNIX. 

SpinWorks can read both SIMPSON spectra and FIDs, but the way in which the data are treated 

is slightly different depending on whether the data are time or frequency domain, and whether 

there are experimental data present.  It is also important to note that there is a slight difference 

between the simulated trace, and the stacked traces. 

1. The size, spectral width and offset of the simulated trace are equivalent to the 

experimental spectrum.  In essence, the spectral characteristics of the simulated trace are 

tied to the experimental spectrum. 

2. The size, spectral width and offset of the stacked traces are independent of the 

experimental data.  Each stacked trace is an independent object, and its spectral 

parameters are copied from the source spectrum when the stacked trace is created.  The 

principal purpose of this is to compare spectra that have been recorded under different 

conditions. 

Spectra with Experimental Data Present 

If SpinWorks has a valid experimental spectrum, SIMPSON spectra can be read with the Read 
Simpson Spectrum selection in the File menu.  The number of data points in the simulated 

spectrum must match the size of the experimental spectrum, and the spectral width of the 

simulated spectrum must match that of the experimental spectrum.  The simulated data are read 

into the simulated trace. 

Spectra with no Experimental Data Present 

In this case, the size and spectral width are read from the SIMPSON .spe file.  The offset is set 

so that the frequencies run from SW at the left end to 0 at the right end.  The spectra are read into 

the simulated trace, but can be copied into the experimental trace (or a stacked trace) if desired. 

If the simulated spectrum is copied into the experimental trace, it is then possible to re-reference 

the data, peak-pick, integrate, etc. 

SIMPSON FIDs 

FIDs produced by SIMPSON are treated as experimental data.  It is just as if the data were 

produced by a virtual spectrometer.  The spectral width and number of data points are 

determined from the data, and the virtual spectrometer frequency (used for Hz to PPM 

conversions) can be set with the SpinWorks Edit Processing Parameters dialog in the Special 

http://nmr.imsb.au.dk/
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Cases group box.  These FIDs can be processed, phased, etc., exactly like experimental data. 

SIMPSON Examples 

REDOR Example 

This is the REDOR example from the J. Magn. Reson. paper.  It should be included with the 

Windows installation of SIMPSON (perhaps as the test.in file), but is also included with 

SpinWorks.  It is assumed that you know how to install and run SIMPSON on your particular 

system. 

1. Run SIMPSON to simulate the REDOR spectrum.  On a Windows system this can be 

done with the command line: simpson.exe redor.in.  This will produce two output files: 

redor.fid and redor .spe. 

2. Start SpinWorks.  Start the processing parameter dialog, and in the F2 panel set the 

Virtual Spectrometer Frequency to 100.56 MHz.  This is a 13C experiment on a 

spectrometer with a proton frequency of 400 MHz.  This number is only used for PPM 

calculations. 

3. From the File menu select Read SIMPSON Spectrum…, and in the dialog select the 

redor.spe file.   The spectrum should look like that in Figure 25 below. 

4. From the File menu select Read SIMPSON Fid…, and in the dialog select the redor.fid 

file. 

5. Set 100 Hz of line broadening and Lorentz windowing.  Process the spectrum.  The 

resulting spectrum should essentially be identical to that in the redor.spe file. 
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Figure 32.   SIMPSON REDOR simulation 
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Figure 33.  SIMPSON QCPMG simulation 
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Running User Supplied External Modules 

Not yet available for SpinWorks 4 

 

A new feature in SpinWorks as of version 1.3 is the ability to use SpinWorks as an interface to a 

user supplied external simulation module.  These modules can be in written in any language (C, 

C++, FORTRAN, Java, etc.), provided that certain conventions are observed.  This feature has 

not been thoroughly tested.  I would enjoy hearing from anyone that has a particular simulation 

program that they would like to use with SpinWorks. 

1. The program must produce its output (digital spectrum) as an ASCII (text) table of 

frequency/intensity (x,y) pairs.  The location of this file must be in SpinWork’s scratch 

folder.  This is set with the Set Preferences… selection in the Options menu.  The name of 

this file must be entered into: User Module Output File, and note that a leading backslash is 

necessary. 

2. If your external program requires an input file (spin system parameters or whatever) the 

name is entered into: User Module Input File, again with a leading backslash.  If your 

external program does not require an input file name (perhaps because it has been hard coded 

into the program ) then enter none.  Note that SpinWorks produces a number of spin 

system files that, depending on exactly what sort of calculation that you are doing, you may 

be able to use as your input file.  These are called “spin_system”, “dnmr.mch” and 

“mexico.mch”.  If none of these are suitable, then it is necessary to edit your own input file 

by starting an editor (e.g. Notepad or WordPad) session and saving your input file before 

each simulation.  You can also select whether your program requires its input file as a 

command line argument or with redirection from “standard input”, UNIX style. 

3. The number of data points (size), the spectral width and the frequency of the left-most point 

in SpinWorks (Simulation menu -> Edit Simulation Parameters…) must match that 

produced by the external program. 

Here is a typical setup: 

 
 



  

SPINWORKS 4.1 MANUAL 98 

 

In this case, the program executable is called “secquad.exe” and is located in C:\Program 
Files\Spinworks.  The program produces an output file called “sequad.out” located in 
C:\Temp.  The program uses as input a manually edited text file called “sequad_test.txt” and 

uses the Redirect operator “<” as part of the input line. 

If you put SpinWorks into simulation debug mode (Simulation menu) you can see that the actual 

command line generated by SpinWorks is: 

C:\Program Files\SpinWorks\secquad.exe < C:\Temp\sequad_test.txt > simout.txt. 
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Summary of Menu Bar Commands 

File Menu Commands 

Open…   

Specifies which NMR data set to open.  The standard Windows File Open dialog.  

Read F1 Trace… and Read F2 Trace…    

Selects JCAMP-DX files to be used as 1D reference spectra (“projections”) in 2D mode.  

E.g. for an HSQC experiment you would select a proton spectrum for F2 and a regular 13C 

spectrum or DEPT 135 spectrum for F1. 

Select Block (Varian)…   

Varian “fid” files can actually contain more than one FID.  This will be the case for 

arrayed parameters or experiments such as DEPT.  Use this command to select which of 

the FIDs should be read. 

Save (JCAMP_DX) and Save as (JCAMP_DX)…   

These functions save the processed spectrum in JCAMP DX format.  To read JCAMP 

DX spectra with SpinWorks set the appropriate data type with the Options menu.  

SpinWorks can also read JCAMP DX spectra create by XwinNMR and XwinNMR can 

convert JCAMP DX spectra created by SpinWorks.  The data sets will have a .dx file 

extension.  Note that these functions always use JCAMP DX format irrespective of the 

Data Format setting.  The JCAMP-DX format used here is a subset of the full definition 

of the format.  In particular, the data are not compressed and compressed data produced 

by other programs cannot be read.  JCAMP-DX files saved by SpinWorks can be read by 

XwinNMR (although XwinNMR may gripe a bit about missing parameters).  JCAMP-

DX files saved by XwinNMR can be read by SpinWorks provided that they are stored in 

uncompressed format.  In XwinNMR, this would be Compression Mode: FIX. 

Save Displayed Rows or Columns...    

Rows or columns selected with the right mouse button can be saved as JCAMP_DX files 

by using the Save Displayed Columns or Save Displayed Rows selections in the File 

menu.  These spectra will be saved with names like row482.dx in the folder containing 

the folder containing the current raw data.  The titles in these files will have the chemical 

shift of the extracted row or column attached.  These rows and columns can then be read 

by SpinWorks in 1D mode, but be sure to set the data type to JCAMP-DX first. 

Save or Read Processed Data (SpinWorks Format)     

These commands save the processed data for the current data set and load any previously 

saved processed data for the current data set.  Processed data can also be automatically 

saved and loaded with the autosave and autoload functions (Options menu).  Note that 

SpinWorks processed data are not complete stand-alone data sets, but become part of the 
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XwinNMR or VNMR data set.  Therefore, in order to read SpinWorks processed data 

you must select the corresponding fid or ser file first.  The presence of SpinWorks 

processed data in the VNMR or XwinNMR data folder does not affect the ability of 

VNMR or XwinNMR to process the data. 

Delete SpinWorks Processed Data    

If SpinWorks has been set to automatically save processed data (Options menu), any 

processed data generated by SpinWorks for this data set can be deleted with this 

command. 

Read Spin System File…   

Reads in a spin system definition (shifts, couplings, etc.) for a simulation.  A standard 

Windows File Open dialog will prompt you for the name and location of the file.  The 

current spin system is also always saved in a file called “spin_system” in the current 

working directory, and is updated any time the spin system changes (e.g. with the 

commands in the Spin System menu).  Files generated by the spin system editor in 

Xsim are compatible with SpinWorks.  If you have the Simulation Mode (Options 

menu) set to DNMR any additional DNMR parameters stored with the file will also be 

loaded.  If you have no experimental data loaded, a descriptive title stored with the spin 

system file will also be loaded.  The title of any experimental data will have precedence 

over this title, however. 

Save Spin System As…   

Saves the current spin system to a named file on disk.  A standard Windows File Save 

dialog will prompt you for the name of the file and the folder to save it in.  This 

command is primarily used to save a spin system for future use and reference.  Files 

saved with this command can be read with the Read Spin System File… command.  

This file is in plain ASCII text and can be examined with any text editor.  These files are 

also compatible with the Xsim program.  Hint:  If you use a consistent file extension for 

your spin system files (such as .ss) they will be easy to recognize, and you can use the 

explorer to associate your favorite editor (e.g. Notepad, Wordpad, etc.) with this file type.  

If you have the Simulation Mode (Options menu) set to DNMR, any DNMR 

parameters will be stored with the parameters.  The data set title (from the experimental 

data set) will also be stored with the spin system file.  If you have not loaded an 

experimental data set, you can enter a title for the spin system file with the Plot Title... 
selection in the Edit menu. 

Read Assigned Transitions…   

Reads a file of assigned transitions into the program.  The current list of assigned 

transitions is also stored into a file called “asn_trans” in the current working directory 

(usually the folder containing the experimental data) whenever an optimizing simulation 

is run.  Transition files produced by SpinWorks are ASCII text files compatible with 

Xsim 
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Save Assigned Transitions As…   

Saves the currently assigned transitions to a named file on disk.  This command is 

primarily used to save the assigned transitions for future use. Files saved with this 

command can be read with the Read Assigned Transitions… command. 

Print…   

Prints the current spectra.  Use the Edit Plot Options and Parameters… command in 

the Edit menu to change various aspects of the output. 

Read Simpson FID…    

Reads in an FID file produced by the Simpson simulation program.  The Simpson options 

must be set to produce the FID file in ASCII. 

Read Simpson Spectrum…   

Reads a spectrum file produced by the Simpson simulation program. The Simpson 

options must be set to produce the spectrum file in ASCII. 

Print Preview   

Exactly what it says. 

Page Setup…   

Sets various printer dependent parameters (which tray to use, landscape vs. portrait, etc.). 

Recent Data Sets…    

The most recently used file list.  The last eight NMR data sets used by SpinWorks are 

displayed in a dialog for possible selection as the current data set. 

Exit 

Edit Menu Commands 

Processing Parameters…  

Use this command to view or change the parameters used to process spectra.  The same 

dialog is used for both 1D and 2D spectra.  For 1D data the F1 page will be labeled inactive.  

Note that in future versions the peak picking parameters may be moved to a separate menu.  

The processing parameters are: 

Size  (drop-down)  

The number of complex data points in the transform.  A Size value greater than TD/2 

results in zero-filling. 

Frequency of 0 ppm (MHz):   

The reference frequency for the spectrum. This value can be used to reference spectra 

that don’t have a convenient reference line.  Particularly useful in solid state NMR. 
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First Point Correction    

The multiplier to be applied to the first point in the FID.  The default value is 0.5, but 

may be adjusted to obtain zero baseline offset. 

Reverse    

Checkbox that selects whether the spectrum should be reversed after transform.  The 

default is off, but may be turned on automatically for the F1 dimension of some 2D 

experiments.  F2 would only require reversal in very rare circumstances. 

Detection mode    

The choices for F2 are: Sequential, Simultaneous, DSP or Custom DSP.  For F1, the 

choices are: COSY/HMBC type, Seq. (currently unused), TPPI, States, States-TPPI 
and Echo-Antiecho.  SpinWorks can usually determine these correctly from the data.  A 

discussion of the F1 detection modes can be found in the 2D processing section of this 

manual.  For F2, this parameter should be correctly extracted from the data parameters, 

but is included here just in case it isn’t. It does not need to be changed unless there is a 

problem. 

Group Delay     

Only available for the Custom DSP Detection mode in F2.  This is the effective delay 

through the digital filters expressed in dwell periods.  For JEOL digital filters, this 

number will typically be about 20.  May also be required for Bruker Data where 

something other than a standard digital filter has been used. 

Special Cases     

F1 only.  Used to adjust the frequency used for Hz to PPM conversion in F1, or other 

special F1 cases.  (Rarely used!) 

Baseline Poly. Degree   

The degree of the polynomial used in the baseline correction routines (Processing 

menu).  The default value is 3 and the maximum value is 6.  (F2 only) 

Left Shift Points   

The FID will be left shifted this many points prior to Fourier transform.  Zeros will be 

added to the end of the FID.  A negative value creates a right shift with zeros being added 

to the beginning of the FID.  For simultaneously sampled data, this is the number if 

complex pairs that have been shifted. (F2 only) 

Peak Pick Minimum Intensity   

The intensity threshold relative to the most intense peak in the spectrum for peak picking.  

Usually adjusted graphically by using the PP Minimum button on the button panel. (F2 

only) 

Peak Pick Noise Threshold   
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provides a degree on noise discrimination in peak picking.  The default value is 0.5 and 

may have to be lowered for spectra that have broad peaks (relative to the digital 

resolution) or that have high degrees of zero-filling. (F2 only) 

Phasing   

Specifies the type of phase correction to be applied to the spectrum after transform. 

Choices are:  None, Constants, Magnitude, Power and Auto (1D only). Using Power 
or Magnitude on the F2 dimension of a 2D spectrum would probably be silly.  Zero: and 

First: specify the zero and first order phase constants that are applied when Phasing is 

set to Constants. 

Window Function (drop-down)    

Select from No Window, Lorentz, Lorentz to Gauss (GM), Sine, Sine Squared, 

TRAF, TRAFS and Gaussian. 

Line Broadening (LB) in Hz.   

The amount of broadening to be applied in an exponential multiplication or Gaussian 

multiplication of the FID.   

Gaussian Factor (GF)   

The Bruker style Gaussian broadening factor to be applied to the FID.  Used in 

conjunction with a negative LB value to provide resolution enhancement.  See the 

description of the Window+FT (Processing menu) command. 

Sine Shift    

The number of degrees that a Sine or Sine Squared window function is shifted.  A value 

of 90 will place the maximum value of the function at the origin of the FID. 

Solvent Filter   

A low pass filter that can be used to remove a strong signal at the centre of the spectrum.  

Primarily cosmetic.  Three filter functions are provided, and the default number of points 

is typical for proton data. (F2 only) 

Automatic Baseline 

This Group Box specifies the parameters used in the fully automatic baseline correction.  

The default values are good for most spectra; however they may be adjusted if necessary.  

The Filter Width and Threshold values are used by the peak detection routine.  They can 

be raised for very noisy spectra.  The Lambda value is the smoothing width used by the 

“Whittaker Smoother” baseline routine.  It should be raised if the baseline routine is 

removing broad peaks from the spectrum (treating them as baseline), or if there are 

closely spaced bands of peaks and the baseline is being driven negative by the smoother. 

Linear Prediction    

Specifies the type of linear prediction applied to the data before transform.  Typically, 
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only backwards LP will be applied to 1D or the F2 dimension of 2D data while only 

forward LP (Zhu-Bax) will be applied to F1.  The value of Cutoff can be raised to speed 

the calculation, if necessary. 

The F1 (Evolution) parameter panel does not include options for solvent filter, peak 

picking or baseline.  Some default values are also different in the F1 panel. 

Plot Options and Parameters…   

Edits sizes, colours, fonts, etc. for the plots.  These should be self-explanatory.   

Display Colours… 

Edits the display colours for the current workspace. 

Restore Default Colours 

 Sets the display colours of the workspace to the default values. 

Set Stored Colour Preferences 

Sets the colours of the current workspace from the Windows registry. 

Copy Metafile to Clipboard (.NET Format)    

Makes a copy of the currently displayed spectra to the system clipboard, for possible 

inclusion in other documents.   This new format is only understood by other .NET 

applications. 

Copy Metafile to Clipboard (Win 32 API Format)    

Makes a copy of the currently displayed spectra to the system clipboard, for possible 

inclusion in other documents.   This format is understood by most other applications, 

including Word and PowerPoint. 

Copy MetaFile to File…   

Saves a metafile copy of the current spectra as a named file.  The format is Windows 

Enhanced Metafile and the file has an emf extension to indicate this.   

HOGWASH Parameters…  

Use this dialog to set and adjust various parameters used by the HOGWASH resolution 

enhancement command.  These parameters are detailed in the separate section dealing 

with HOGWASH.  

Start Up Options…   

Allows you to set such start-up defaults as default data path, default scratch path, 

autosave and autoload functions, etc.  These values are saved in the Windows registry. 

Binning Parameters… 

Sets the start and stop points, bin width and binning method for data binning (Peak Pick 

menu). 
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Plot Title…   

Use this command to edit the title of the current data.  This information is displayed at the 

top of the data window and is included on the plot.  The default is to use the title stored 

with the data.  Note that currently only the first line of the title file is read and displayed. 

View Menu Commands 

Tracking Cursor    

This option selection turns ON and OFF a tracking vertical reference line (or cross-hairs, 

for 2D). This can be very useful for measuring frequencies, frequency differences, etc.  

The default value is ON. 

Peaks and Match    

This option toggles the display of peak pick labels and the match lines between 

experimental and simulated spectra.  Available for 1D only. 

Rotate 2D    

This selection will cause 2D spectra to be displayed and printed with the F1 axis 

horizontal.  A check mark and the axis labeling indicated whether the spectra are rotated 

or not.  Note that this option must be turned off for interactive 2D phasing. 

2D Contour Spacing    

This sub-menu allows you to select linear or logarithmic spacing for the 2D contour 

levels.  The default is logarithmic. 

Set Fixed Limits and Set Fixed Scale   

Use these commands to set convenient plot limits and expansion scales for routine 

spectroscopy. Once an expansion scale has been set (e.g. 10 Hz/cm) it is possible to scroll 

through the spectrum at the same scale by using the slider at the bottom of the data 

window. 

Define ROI…    

Define up to three regions of interest.  You can toggle between these regions with the 

ROI menu or with the 1, 2 or 3 keyboard shortcut keys.  You can also define the 

currently displayed region of the spectrum as a region of interest with <ctrl>1, <ctrl>2 or 

<ctrl>3. 

Show Spectrum     

Use this command to turn the display of the experimental spectrum on or off.  This will 

affect both the display and the print.  The default state is ON, and a check mark is used to 

indicate this fact. 

Show Simulated   
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Use this command to turn the display of the simulated (calculated) spectrum on or off.   

The default state is ON, and a check mark is used to indicate this fact. To control 

printing of the simulated spectrum use the Plot Options and Parameters… selection in 

the Edit menu. 

Show Integrals   

Use this command to turn display of the integrals on or off.  The default state is ON, and 

a check mark is used to indicate this fact.  To control printing of the integrals use the 

Plot Options and Parameters… selection in the Edit menu. 

Show Zero Line   

Use this command to turn display of the true zero line on or off.  Can be useful for 

phasing or manual baseline correction. 

FID Display 

Use this command to toggle between FID and spectrum display. 

3D XY planes 

Shows 3D planes in XY mode. 

3D XZ planes 

Shows 3D planes in XZ mode.  YZ mode is not currently available. 

Copy to Inset Box    

Copies the region of the spectrum currently defined by the cursors to a separate window.  

Typically used for displaying expansions.  In 1D, these inset spectra will also be printed 

with the same expansion, size and location as seen on the screen.  Printing of 2D insets is 

not yet supported. 

Copy Experimental to Stack   

Use this commands to make a copy of the processed experimental spectrum into a 

stacked plot.  This makes it possible to compare a series of spectra such as a temperature 

run or DEPT sequence on the screen.   Zooming and scrolling effect all of the traces.  If it 

is necessary to adjust the vertical scaling of an individual trace, use the Define Stacked 
Trace Properties… command of the View menu.  This dialog can also be used to adjust 

the vertical and horizontal offset of the traces.  The Subtract Trace from Experimental 

command in the Processing menu can be used to produce a difference spectrum. 

Copy Simulated to Stack   

Similar to the above, but copies the simulated spectrum to the stack.  These stacked traces 

can contain a mixture of simulated and experimental spectra. 

Add Simulated to Stack   
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Occasionally, it is handy to break a simulation up into a number of smaller simulations.  

This command allows you to build up a composite simulation in the last stacked trace by 

adding the current simulated spectrum to the spectrum in the trace..  Stated another way, 

trace2 = trace2 + (factor * simulated).  The factor or coefficient for the simulated can be 

changed from the default value of 1 in the Scale/Shift Stacked or Inset Traces… 

dialog. 

Copy Series of Bruker Experiment Numbers to Stack 

A series of Bruker experiments with consecutive experiment numbers (e.g. a 1D NOE 

series) can be copied to the stack with this command. 

“dssh” Type Stacked Trace. 

Generates a horizontal stacking of a series of experiments, very much like the 

Varian/Agilent “dssh” command. 

Copy Simulated to Experimental    

Copies the current simulated spectrum into the experimental trace, overwriting any 

experimental data.  This allows one to use the integration and peak picking routines on 

simulated data, primarily for teaching purposes. 

Add Simulated to Experimental    

Adds the current simulated spectrum to the experimental trace, overwriting any 

experimental data.  This allows one to use the integration and peak picking routines on 

simulated data, primarily for teaching purposes. 

Copy Experimental to Simulated    

Can’t quite see the point to this one, but it is there. 

Delete Stacked Trace    

Use these command to delete the last stacked trace.  The current experimental spectrum is 

not affected. 

Delete Stacked Traces    

Deletes all of the stacked traces. 

Define Stacked Trace Properties…    

Starts a dialog which allows you to adjust the scaling, labeling, colour, offsets, etc. of the 

stacked traces. 

F2 Axis:  PPM/Hz     

Toggles the axis units of the F2 axis between PPM and Hz. 

F1 Axis:  PPM/Hz     

Toggles the axis units of the F1 axis between PPM and Hz. 
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ROI Menu Commands 

This menu allows you to select up to three pre-defined regions of interest, or to start a dialog 

where up to three regions of interest may be defined. 

Option Menu Commands 

Data Format  (sub menu)  

This menu selection sets the format of the current data.  Currently supported data formats 

are: Bruker UXNMR/XwinNMR/TopSpin, and Varian UNITY/INOVA.  Current JEOL 

spectrometers do not record their data in this format but can convert it to this format.  It 

may be necessary to reverse (Processing menu) converted JEOL data after transform. 

TECMAG JCAMP DX format is used to read spectra saved by SpinWorks or JCAMP DX 

files from other sources (e.g. XwinNMR).  The File: Save As... function always saves 

data in JCAMP DX format irrespective of the Data Format setting.  The Data Format 
sub-menu is also used to switch the program from 1D to 2D modes.   

Set Start-up Options…   

A number of start-up preferences can be set with this dialog: 

Default Data Path    

Sets the initial data folder (directory) for the File Open command.  e.g. F: or 

D:\data\marat\nmr.   

External Module Path    

Sets where the program expects to find external simulation modules such as 

DNMR3 and MEXICO.  The default is C:\Program Files\SpinWorks. 

Writable Scratch Path 

Sets the scratch directory (folder) used by some of the calculations.  The default is 

C:\Temp is should be acceptable for most users.  This folder must exist, and must 

be writable in order to perform calculations. For DNMR3 calculations the scratch 

path must be set to C:\Temp. 

Processed Data    

Two check boxes that determine whether processed data should be stored to disk 

and automatically loaded upon selection of a data-set.  These features only apply 

to Varian and Bruker XwinNMR/UXNMR data.  Occasionally, an inconsistently 

processed data set can cause the Auto Load feature to fail and SpinWorks may 

crash.  This most often happens when the parameters say that the data were of one 

type (e.g. States), but this designation was wrong and the selection was 

overridden when the data were processed.  If this happens, re-start SpinWorks and 

turn the Auto Load feature off (unchecked) before selecting the data set. 

Display Font Size 
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Gives a choice or “normal”, “larger” and “largest” for the fonts used in the data 

window.  Note that with the “larger” or “largest” settings the dialog and fonts will 

also be larger. 

A4 (European) Paper Size. 

Sets default plot sizes suitable for European A4 paper size. 

Alternate Print Dialog (for Windows 7 64 bit) 

Uses an alternate (Windows XP style) print dialog as a work-around for a bug in 

.NET for 64 bit Windows 7. 

Start-Up Size 

Sets the size (width and height) of the SpinWorks Window at start-up.  Why?  

Because someone asked for it. 

Extended Debug Logging 

Turns on detailed logging (tracing) of SpinWorks actions.  These will be written 

into a file called SW_error.log in the current scratch folder (usually C:\Temp).  

This information can be very informative in the event of a problem with the 

program. 

Clear Log File 

Deletes the log file to keep it from getting too large. 

Spin System Menu Commands 

Edit Chemical Shifts…   

This command starts the chemical shift editor, where it is possible to enter the number of 

spins, chemical shift, group label, species and spin identifiers for a group.  The standard 

spin systems provided in the simulation tutorial give good examples of the required 

format.   Note that if you don’t provide a group label a default label will be used.  This 

label can be overwritten by the user at any time. 

Edit Scalar (J) Couplings…   

This command starts the coupling editor, where all J couplings relevant to the spin 

system can be edited.  Note that the chemical shift editor must be called first.   

Edit Dipolar (D) Couplings…  

Dipolar coupling is now supported for NUMMRIT (but not DNMR or MEXICO) 

calculations.   

Edit Simulation Options and DNMR Parameters… 

This command starts a dialog where it is possible to edit the simulation parameters.  This 

dialog is also used to set the necessary dynamic NMR parameters for DNMR or 
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MEXICO simulations.  See the Dynamic NMR section for details of the DNMR 

parameters.  

Display Linewidth (Hz.)   

This is the linewidth (Lorentzian or Gaussian) used for in the calculation of the 

simulated spectrum.  The default value is 0.5 Hz. 

Grouping linewidth (Hz.)   

The linewidth used for grouping near degenerate peaks in a peak listing.  This 

value does not normally need adjustment. 

Transition Threshold   

The minimum intensity for calculated transitions to be saved.  Too high a value 

may cause some small transitions to be missed.  Very large tightly coupled spin 

systems generate large numbers of very weak (and usually unobservable) 

transitions.  Too low a value may cause transition table to overflow on these 

systems.  The default value of 0.01 is suitable for most cases. 

Size (data points)   

The number of points used in the calculation of the simulated spectrum.  The 

default value is 16k.  In an experimental spectrum has been read the size 

parameter from the experimental data will be used instead. 

Display Width (Hz)  

The width of the spectral window used to calculate the simulated spectrum.  If an 

experimental spectrum has been read, the spectral width parameter from the 

experimental data will be used instead. 

Offset (leftmost frequency in Hz)   

The frequency of the left-most simulated data point in Hz.  If an experimental 

spectrum has been read, the corresponding parameter from the experimental data 

will be used instead. 

Spectrometer Frequency (MHz)   

The frequency used to convert from Hz to ppm for the axis of the simulated 

spectrum. If an experimental spectrum has been read, the corresponding 

parameter from the experimental data will be used instead. 

Maximum number of iterations   

Puts a limit on the number of iterations allowed in an iterative simulation.  The 

default value is 30. 

RMS limit for convergence (Hz)   
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An iterative simulation (optimization) will stop if the RMS deviation between the 

experimental and simulated peak frequencies falls below this level. 

RMS level for autoassign (Hz)   

The RMS deviation must fall below this level for automatic assignment to occur.  

The default is 0.1 Hz and the maximum value is 10 Hz.  The default is suitable for 

high resolution spectroscopy and can be raised to 1 to 2 Hz for more routine work. 

Allowable variation in pars   

The allowable variation in a parameter during an iteration.  The default value is 

25% and the minimum value is 1%.  This parameter rarely requires adjustment. 

RMS factor for autoassign   

Transitions with frequency differences within this factor times the current RMS 

deviation will be automatically assigned.  The default value is 2.7 and the 

minimum allowed value is 1.28.  This value must be less than the RMS factor for 

autoignore.  This parameter rarely requires adjustment. 

RMS factor for autoignore   

Transitions with absolute differences greater than this value times the current 

RMS deviation will be automatically ignored during an optimization.  The default 

value is 3, and the minimum allowed value is 1.6.  This parameter rarely requires 

adjustment. 

Iterations between each autoassignment   

The number of iterations between each autoassignment.  The default value of 3 

rarely requires adjustment. 

Optimize check box   

Determines whether an iterative simulation (optimization) should be performed.  

The default value is OFF.  Make sure that you have selected some parameters for 

optimization (Spin System menu) and that you have assigned sufficient transitions 

before running an iterative simulation. 

Autoassign check box  

Determines if transitions should be automatically assigned during an optimization.  

The default value is ON.  Note that using Autoassign too early in a difficult 

analysis can lead to problems. 

Autoignore check box   

Determines if transitions with excessively large deviations should be ignored (and 

possibly Autoassigned) during an optimization.  The default value is ON.  This 

parameter should generally be left ON unless you really know what you are 

doing. 
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Simulation Timeout (sec.) 

Specifies the maximum time that a simulation is allowed to run.  The default 

value of 10 sec. should be good for most simulations on most computers.  For 

very large spin systems on really old computers you may have to increase this 

value. 

Simulation Menu Commands 

Simulation Mode   

Use this command to set the simulation mode to either NUMMRIT, which is used for 

spin simulation, iterative analysis, and double resonance simulation, or to 

DNMR/MEXICO which is used to simulate dynamic NMR experiments, or to 

Deconvolution for band-fitting. The default mode is NUMMRIT. 

Run NUMMRIT Simulation   

This command calculates a simulated spectrum based on the current spin system, 

Simulation Parameters and Simulation Mode (Options menu). After a calculation the 

calculated (simulated) spectrum will be displayed along with the experimental spectrum 

(if any). 

Run DNMR Simulation   

Runs DNMR3 as an external program. 

Run MEXICO Simulation   

Runs Alex Bain’s MEXICO program as an external program. 

Run Deconvolution   

Generates a simulated spectrum based on the current deconvolution peaks list.  More 

commonly, this will be done with the interactive deconvolution panel. 

List Simulation Output   

Starts an MS Notepad session with the textual output of the last simulation run.  Also, use 

this command to print the simulation output. 

Load Optimized Parameters   

This command loads the post-optimization parameters into the coupling and shift editors 

for further refinement.  They can then also be saved with the Save Spin System… 

command of the Edit menu. 

Autoassign Peaks in Region    

Automatically assigns the transitions to observed peaks in the displayed region. The peak 

picking threshold and sensitivity values are used for peak assignment.  If no observed 
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peak can be found within a certain distance of the transition cursor, or if the peak is 

below the peak picking threshold or sensitivity, no peak will be assigned.  Single 

transitions can be assigned with the keyboard “a” key. 

Edit Deconvolution Peak Parameters… 

With this dialog you can enter or edit peak parameters (frequency, intensity, width, % 

Gaussian) for the deconvolution peak list.  

Copy Picked Peaks to Deconvolution List 

Uses the current peak pick list (generated by the peak picking commands) to generate the 

peak list for deconvolution.  This will generate   estimated values for the frequency and 

amplitude of each peak, with a default value for the width. 

Interactive Deconvolution Panel 

This stay-up dialog box will allow you to interactively adjust and optimize the parameters 

of the deconvolution peaks.  You can also transfer copies of the individual peaks to the 

stack display.  To copy the simulated spectrum to the stack display, use the Copy 
Simulated to Stack function in the View menu. 

Delete Assigned Peaks in Region    

Deletes all transition assignments in the displayed region. Single transition assignments 

can be deleted with the keyboard “d” key. 

Calculate RMS 

Calculates and displays the current normalized RMS deviation between the simulated 

spectrum and the experimental spectrum.  This command usually used for DNMR3 or 

MEXICO calculations.  For deconvolution analysis, an unnormalized RMS is displayed 

in the Interactive Deconvolution Panel.  The RMS is calculated over the displayed 

region of the spectrum only. 

Processing Menu Commands 

Note that the button panel Process button is more commonly used for basic processing. 

FT   

Performs a Fourier transform of the current FID with no window function.  Uses the Size 
parameter from the Edit Processing Parameters… dialog (Edit menu).  Usually, the 

Window + FT command is more appropriate. 

Window + FT   
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Applies the specified window function followed by Fourier transform of the current FID.  

Uses the LB, GF, Size and Window Function parameters from the Processing 
Parameters… dialog (Edit menu).  For 1D, the window parameter functions may also 

be set with the toolbar.   For a Lorentz window function, a typical value for LB is 

1/(acquisition time) or equal to the natural linewidth if the peaks are broader than this 

value.  A Lorentz to Gauss window function will perform a Bruker-style Lorentz to 

Gauss resolution enhancement.  Typically, set LB to the negative of the observed 

linewidth and GB to the fractional point in the time domain where the signal vanishes 

into the noise.  e.g.  If the acquisition time is 5 seconds and the signal disappears into the 

noise by 2 seconds then GB should be set to 0.4.  These are only trial parameters, and 

may need to be readjusted to suit particular circumstances.  

Window + FT+ Phase    

Applies the specified window function followed by Fourier transform of the current FID 

followed by phase correction with the last specified phase constants.  This is equivalent 

to the Bruker “efp” command or the Varian “wft” command. 

Process Series of ExNo (Bruker) 

Applies a weighted Fourier transform to all experiments in a contiguous series of 

experiment numbers (Bruker data).  Each block will also be phased if Last Constants is 

specified as the phasing parameter. Typically used for experiments such as 1D NOE. 

Process Array (Bruker) 

Applies a weighted Fourier transform to all blocks of an arrayed experiment (Bruker 

data) where the individual FIDs are stored in an ‘SER” file (a pseudo-2D experiment).  

Each block will also be phased if Last Constants is specified as the phasing parameter.  

After transform, the blocks will be displayed as a stacked plot.  Typically used for 

experiments such as T1. 

Process Array   (Varian and Anasazi) 

Applies a weighted Fourier transform to all blocks of an arrayed experiment (Varian and 

Anasazi data).  Each block will also be phased if Last Constants is specified as the 

phasing parameter.  After transform, the blocks will be displayed as a stacked plot. 

Least Squares Baseline Correct Array  

After defining a series of baseline points (Yellow BL Point button), this function will 

apply a least squares baseline correction to all spectra in an array.  The degree of 

polynomial used can be adjusted in the processing parameters dialog.  See the detailed 

description under Automatic Baseline (Least Squares)  below. 

Spline Baseline Correct Array  

After defining a series of baseline points (Yellow BL Point button), this function will 

apply a cubic spline baseline correction to all spectra in an array. See the detailed 

description under Automatic Baseline  (Spline)  below. 
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Auto Baseline Correct Array  

Do a fully automatic baseline correction of a stacked array. 

Integrate Stacked Array  

This function will provide an integral list for all spectra in an array.  You must first define 

the integral regions in the active trace.  The absolute integrals will be listed in two 

formats:  the first by trace number and the second by peak number.  The later may be 

preferable if you want to paste the data into a spread sheet. 

Drift Correct  

 Applies a Varian style linear baseline correction to the spectrum. 

Baseline Correct (Spline)   

This command applies a cubic spline correction to the displayed region of the spectrum.   

It is first necessary to define some baseline points.  This is accomplished by clicking on 

the yellow BL Point button on the button panel.  Then use the mouse to define at least six 

points in the displayed region that represent baseline.  More points are better.  Note that 

the baseline point routine averages a region 16 points wide, so don’t select points close to 

large peaks.  After selecting enough points, click on the return button (or the keyboard 

Enter/Return key) to exit the baseline points routine.  Finally, execute the Automatic 
Baseline  (Spline) command. 

Baseline  Correct (Least Squares)   

This command applies a polynomial baseline correction to the displayed region of the 

spectrum. The default polynomial order is 3, and may be changed in the Edit Processing 
Parameters… dialog (Edit menu).  It is first necessary to define some baseline points.  

This is accomplished by clicking on the yellow BL Point button on the button panel.  

Then use the mouse to define at least six points in the displayed region that represent 

baseline.  More points are better, and it is important to include points near each end of the 

region.  Note that the baseline point routine averages a region 16 points wide, so don’t 

select points close to large peaks.  After selecting enough points, click on the return 

button (or the keyboard Enter/Return key) to exit the baseline points routine.  Finally, 

execute the Automatic Baseline  (Least Squares) command. 

Clear Baseline Points     

Clears the defined baseline points. 

Fully Automatic Baseline Correction    

Applies a spline correction to the baseline, but determines the baseline points 

automatically.  This procedure works well for spectra with clear regions of baseline and a 

decent signal to noise ratio. 

Reverse 1D Spectrum     
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Reverses the spectrum – high field to low field.  There are several circumstances where 

this may be appropriate: 

1. Exchange of the two quadrature channels will reverse the spectrum (This is the 

default state on Varian and JEOL spectrometers. Therefore, Varian and JEOL data are 

automatically reversed by SpinWorks). 

2. If a spectrum has a distinct baseline curvature at the left (low field) end of the 

spectrum, it is possible to straighten it by reversing the spectrum, using the least 

squares automatic baseline routine, and then reversing the spectrum back to the 

normal orientation. 

HOGWASH  

Applies Ray Freeman’s HOGWASH procedure to the displayed region of the spectrum. 

The HOWGASH parameters must first be set (Edit menu).  Please see the HOGWASH 

section of this manual for details. 

2D Processing (sub menu)    

Contains assorted 2D processing commands that are not included in the 2D button panel: 

Symmetrize     

Applies a symmetrization algorithm to the data.  The data must be inherently 

symmetric.  That is, the size, spectral width and referencing must be identical in 

the two dimensions, as should be the case with COSY data. This routine is 

frowned upon by spectroscopists, but is still commonly used.  The chief problem 

is that it can turn an obvious artifact such as T1 noise or tailing into something that 

looks like a real cross peak.  Correcting the problem at source (vibration isolation, 

stable instrument environment, better phase cycling, using gradients, etc.) is a 

better if not always practical solution. 

Smooth    

Applies a smoothing algorithm to the data.  This command will improve S:N 

slightly and will “smooth-out” jagged contours.  Usually, time domain processing 

(adjusting window function, zero-filling, linear prediction, etc.) is preferred. 

Baseline F2 and Baseline F1    

Applies an automatic baseline correction to the rows or columns of the 2D matrix.  

Rarely required when working in organic solvents, but may be useful for samples 

recorded in water. 

Drift Correct F2 and F2   

Apply a Varian/Agilent style drift correction (first order baseline correction) to 

the rows or columns.  This is useful when some baseline flattening is desired but 

polynomial baseline correction is inappropriate. 

HOGWASH (F1)    
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Applies Ray Freeman’s HOGWASH procedure to the F1 dimension displayed 

region of the spectrum.  The HOWGASH parameters must first be set (Edit 
menu).  Please see the HOGWASH section of this manual for details. 

Calculate F1 and F2 Skyline Projections   

These commands calculate the F1 or F2 projections of the data, and save the 

projections in the current data folder as JCAMP-DX files with file names 

f1_proj.dx and f2_proj.dx.  An F1 projection of HSQC and/or HMBC data is 

particularly useful for samples that are too dilute for conventional 13C 

spectroscopy in a reasonable amount of time.  These commands are also available 

in the 2D Processing and Display Dialog.  When activated from this dialog, the 

projections will also be displayed along the edges of the 2D spectrum and can be 

printed with the 2D spectrum as well. 

Calculate F1 and F2 Sum Projections   

These commands calculate the F1 or F2 sum projections of the data, and save the 

projections in the current data folder as JCAMP-DX files with file names 

f1_proj.dx and f2_proj.dx.  A sum projection will usually have poorer signal to 

noise ratio than a skyline projection. 

Clear Imaginary Data 

This command clears 2D imaginary data for the current workspace, thus freeing 

some of your computer’s memory.  A copy of the all quadrants of the data is 

automatically saved on disk (The File Save command is issued) before the 

imaginary quadrants are cleared.  Although you can regenerate the imaginary 

quadrants (for phasing) using the Hilbert transform functions, it is better to simply 

read back in the full processed data (File menu). 

Hilbert Transform F2 or F1 

These commands re-generate the imaginary data for processed 2D data.  These 

commands are normally used with processed 2D and 3D data from the NMRPIPE 

program. 

Auto Reference F1  

An automatic referencing of F1 for many experiments can be accomplished using the 

Auto Reference F1 sub menu in the Processing menu. Select the F1 nucleus and solvent 

appropriate to your data.  This procedure assumes that the F2 dimension is proton, and 

has been correctly referenced.  The reference values used are valid for dilute solutions at 

25C.  A homonuclear option will set the referencing in F1 to be the same as that in F2.  

This command makes use of the constant ratio of the reference peak in proton vs. that of 

the X nucleus, for a given solvent and temperature. 

Hilbert Transform 

This command will re-generate the imaginary data it is not available.  This would most 
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likely be used with JCAMP-DX data where the imaginaries are not available.  You would 

need the imaginary data if you wanted to phase the spectrum. 

Subtract Trace 2 from Experimental   

This command can be used to create a difference spectrum by subtracting trace 2 from 

the current experimental spectrum.  For example, to process an NOE difference 

experiment: 

1. Process the reference (off resonance) spectrum normally with the Process button 

command (or Processing menu) followed by phasing.  Do not apply baseline 

correction at this point. 

2. Transfer a copy of the processed reference spectrum to trace 2 with the Copy 
Experimental to Stack command in the View menu. 

3. Open one of the on-resonance NOE experiments (File menu) and process it with the 

Process button (or Processing menu). Do not use baseline correction. 

4. Use the Subtract Trace 2 from Experimental command (Processing menu) to 

replace the current experimental spectrum with the difference between the two.  If 

necessary, apply baseline correction now. 

5. Peak pick, integrate, and plot the difference spectrum as desired 

6. Repeat steps 3 to 5 for each of the on-resonance NOE experiments in the run. 

7. Anyone with gradients will, of course, be using the GOESY experiment instead.  

Add Trace 2 to Experimental   

This command can be used to create the sum of two spectra by adding trace 2 to the 

current experimental spectrum.  

MQMAS Toolbox…    

Use this dialog to calculate the required phase angle or adjust the referencing for the 2D 
Shearing Transform. 

2D Shearing Transform    

Applies a T1 dependent first order phase correction to the rows of a 2D data set.  This 

transform is used to generate orthogonal MQ and MAS dimensions in a MQMAS 

experiment.  The phase angle requires depends on the spin of the nucleus and, the 

quantum selection of the experiment, and the spectral widths in both dimensions.  The 

shearing angle is most conveniently calculated using the MQMAS Toolbox…  Dialog 

(2D Processing sub-menu). 

FID Math Toolbox…    

This dialog can be used for FID manipulation.  Hypercomplex 2D data can be split into 

separate files, FIDs can be phased and combined in various ways.  Please see the 
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appropriate section of this manual for details.  These are advanced features, and are not 

required for typical 2D processing. 

Convert Field (For 2D reference)   

Occasionally, it is handy to use a 1D spectrum recorded at a different field as a reference 

for a 2D spectrum.  For example, we often record superb HSQC spectra on our AMX500.  

However, we don’t have a decent 13C observe probe for this instrument.  With the field 

convert feature, we can use a 13C spectrum recorded on our INOVA 600 or Avance 300 

as a reference spectrum. 

The Field Convert function has a dialog which will display the current transmitter 

frequency, and allow you to enter the target transmitter frequency.  Make sure that you 

use the transmitter frequency.  This will be SFO1 (or SFO2 or SFO3) for Bruker data 

and sfrq (or dfrq or dfrq2) for Varian data.  After the conversion process, save the 

spectrum as a JCAMP-DX file.  This file can then be used as a 1D reference spectrum for 

2D spectra. 

Note that this procedure is most appropriate for fully decoupled spectra like 13C, and 

would not generally be useful for proton spectra. 

Peaks and Integrals Menu Commands  

Pick Peaks and Append to List   

Picks the peaks in the currently displayed region and appends them to the peak list.  The 

minimum intensity for peak picking is displayed as a dashed line across the screen and 

can be changed by dragging it with the small box displayed at the left end of the line.  

This value, along with the noise discrimination parameter can be changed manually with 

the 1D Processing Parameters… dialog in the Edit menu. 

Clear Peak List    

Erases all of the picked peaks. 

Clear Peaks in Region   

Erases only those peaks in the displayed region. 

Peak Pick or Integrate Stacked Array   

Picks a peak at the cursor defined frequency in an arrayed experiment.  You must use one 

of the Process Array command in the Processing menu first.  If a frequency range is 

defined with two cursors than the integral over that region is listed. 

Load 1D Peaks  

Loads previously picked peaks.  Note that the referencing must be identical to the 

original spectrum for the peak labels to be accurate. 

Load 2D Peak Assignments 
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Loads previously assigned 2D peaks. 

List Peaks 

Displays the peaks in for possible printing.  The program will use whatever program is 

defined for a “.txt” file – usually MS notepad or WordPad. 

List Integrals 

Displays the integrals in for possible printing. The program will use whatever program is 

defined for a “.txt” file – usually MS notepad or WordPad. 

Interpolation   

Determines whether parabolic peak interpolation is to be used for the calibration and 

peak assignment routines.  If turned OFF, the raw cursor frequency will be used instead.  

The default value is ON. 

Sign    

Determines whether only positive peaks, negative peaks, or both positive and negative 

peaks should be picked. 

Units   

Selects PPM or Hz as the units for the on-plot peak list and display.  This is independent 

of the axis units. 

Digits to Right of Decimal (Peaks)   

Sets the number of digits displayed and printed to the right of the decimal for peak 

picking. 

Digits to Right of Decimal (Integrals)   

Sets the number of digits displayed and printed to the right of the decimal for integrals. 

Calibrate…   

Sets a particular peak or point in the spectrum to a particular shift.  Enter in the same 

units as the axis display.  Also available on the button panel. 

Bin data 

Divides the data set into a set of “bins” and reports the integral, mean or maximum value 

in each bin.  The binning method, bin width, and start and stop points can be set with the 

Edit Binning Parameters… dialog available in the Edit menu. 

The peak pick minimum intensity and noise threshold can also be entered in this menu as the last 

two items. 



  

SPINWORKS 4.1 MANUAL 121 

 

Commands Available with the Command Line 

Processing Commands: 

The following commands can be used to process 1D data.  Many of the commands require that 

the appropriate processing parameters (e.g. LB or GF) be set first.  This can be most easily done 

with the Processing Parameters dialog (Edit menu or edp command), or by giving one of the 

parameter commands listed below.  Many of the commands have several aliases.  This is so that 

the commands will hopefully be familiar to both Bruker and Varian users. 

 ft  Fourier transform of FID. 

 ef  Window multiplication followed by Fourier transform.  The window function  

used is specified by the Window parameter (toolbar of Processsing Parameter 
dialog) 

 efp  Window multiplication followed by Fourier transform and phase 

correction with previous phase constants. (Alias: wft)  Note that commands like 

gfp, trafft, etc. that were available in earlier versions have been removed.  To use 

these window functions, set the window parameter (toolbar or Processing 
Parameter dialog) and use the efp command. 

 process Process the data (1D or 2D with the window and phasing parameters defined in 

the processing parameters (toolbar or dialog).  Alias: proc. 

 pk  Apply previous phase constants. (alias: phase) 

 pk_f1 Apply previous phase constants in F1. (alias: phase_f1) 

 apk Automatic phase correction. 

 abs Automatic baseline correction using a polynomial and defined points.   

 fabs Automatic baseline correction with automatic Whittiker smoother. 

 rev  Reverse spectrum, low field to high field. 

 hw  HOGWASH enhance the displayed region of the spectrum.  You must define the  

  parameters in the HOGWASH Parameters dialog (Edit menu or edhw)  first.   

  Alias: hogwash 

File Handling Commands 

 open Opens a new NMR data set. 

 re # Reads experiment number # for UXNMR/XwinNMR data only.  For example, if 

you are currently working on the proton spectrum mydata/1 and you want to 

switch to the carbon spectrum mydata/4, using the command re 4 will switch 

you to the carbon data set without going through the file open dialog.  Alias:   
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read #.  

Simulation Commands 

The following commands can be used to run the various SpinWorks simulation routines.  The 

program must be in the correct mode (NUMMRIT or DNMR/MEXICO) before running the 

simulation, and you must edit the parameters first (Spin System or Simulation menus). 

 sim Run a NUMMRIT simulation. 

 dnmr Run DNMR simulation. 

 mexico Run MEXICO simulation. 

Parameter Editing Commands: 

 edproc Edit processing parameters (1D and 2D).  Alias: edp. 

 edplot Edit plotting parameters. 

 edshifts Edit the chemical shifts for a simulation. 

 edtitle Edit the plot title.  Alias: setti. 

 edj  Edit scalar coupling constants for a NUMMRIT or DNMR simulation. 

 edd Edit dipolar couplings for a NUMMRIT simulation. 

 edsim Edit general simulation parameters for a simulation, including DNMR parameters. 

Parameters that Can Be Set with the Command Line: 

Many SpinWorks parameters can also be entered on the command line.  They are entered by 

typing the number followed by the value.  e.g. lb 1.2 changes the value of the LB parameter to 

1.2 Hz. 

 lb  Exponential line broadening, in Hz. 

 gf  Gaussian broadening factor (Bruker style). 

 size Transform size in complex points.  i.e. 8182 means 8192 real points plus 8192 

imaginary points. Aliases: si, fn.  This value must be a power of 2, and will be 

rounded up to the nearest power of 2 if it isn’t. 

 ph0 Zero order phase constant. Alias: PHC0 and phase0. 

 ph1 First order phase constant. Alias: PHC1 and phase0.  

 ph0_f1 Zero order phase constant in F1. Alias: PHC0_f1 and phase0_f1. 

 ph1_f1 First order phase constant in F1. Alias: PHC1_f1 and phase0_f1.  

 vscale Sets the vertical scaling of the spectrum.  The current vertical scaling is shown  

  just above the axis at the left side of the screen. Alias: vs 
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 floor Adjusts the 2D contouring floor (lowest displayed level) by the given factor.  e.g. 

floor 1.5 will raise the floor by a factor of 1.5. 

 range Adjusts the range of the 2D contours (the difference between the lowest and 

highest levels) by the given factor. 
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Format of SpinWorks Processed Data 

SpinWorks writes its processed data in the same folder as the original FID file.  The processed 

data consists of several files: 

 1D_par, 2D_par, 3D_par These are the parameter files for the processed data.  They 

are “human readable” ASCII text files, and the parameters 

should be self-explanatory.  Note that the SF parameter is 

the frequency (in MHz) of 0 ppm.  This is equivalent to 

the Bruker SF parameter. 

 1D_real, 1D_imag The real and imaginary parts of a 1D processed spectrum.  

The data are signed 32 bit integers, with the byte order of 

the INTEL processors. 

 2D_rr,…, 2D_ii The four hypercomplex quadrants of a processed 2D 

spectrum.  The data are signed 32 bit integers (INTEL byte 

order), and are stored in a row-major fashion. 

 1D_integ, 2D_integ ASCII integration region files for 1D and 2D data. 

 SW_3D (folder) The folder containing the SpinWorks processed 3D data, 

containing: 

 3D_XYt_rr.1  etc.  3D planes processed in X and Y but time domain in Z. 

 3D_XZt_rr.1  etc.  3D planes processed in X and Z but time domain in Y. 

 3D_XYZ_rrr.1 etc.  3D planes processed in X, Y and Z. 

Note that several SpinWorks commands (e.g. peak picking, simulation, etc.) also produce ASCII 

output files that are also stored in the current data directory. 
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spectrum.dx, 17 
Spin System menu commands, 109 
Spline Baseline Correct Array, 114 
Split Hypercomplex 2D Data into Separate Files 

Fid Math, 66 
Stack button 

Deconvolution Dialog, 37 
stacked traces, 15 

Start-Up Size, 109 
States, 5, 6, 41, 42, 57, 58 

3D Processing - Varian/Agilent, 61 
States-TPPI, 5, 41, 42, 57 
Subtract Trace 2 from Experimental 

Processing menu, 118 
Symmetrize 
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